Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable search if resolve failed

  • 4 replies
  • 1 has this problem
  • 12 views
  • Last reply by namjos

more options

Hi,

With recents versions of Firefox (I cant' tell which), when you type an adress and resolve of this adress failed, firefox is running a search with this adress as parameter. I want to disable this feature, as this can be a security problem when typing internal servers private urls. You have to put "http(s)://" to disable the feature I've separated main adress and search input, disabled autocompletion, but the main adress is still making searchs.

Regards

Chosen solution

You can set keyword.enabled = false on the about:config page to disable searching via the location bar.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

You can set keyword.enabled = false on the about:config page to disable searching via the location bar.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Helpful?

more options

Thanks :)

Helpful?

more options

I notice that you are behind on Firefox updates and still use an outdated Firefox 83 version with disclosed security vulnerabilities.

Any specific reason why you aren't using the current release (85.0.2)?

Helpful?

more options

It's my work office firefox, mozilla update website is blocked by firewall and it's a mess to upgrade it ;) I will do it manually

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.