Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Weird font on some website's

more options

Hi,

I need help, on some website's the font has strange symbols.. see the screenshot. how can i fix this? this is pretty annoying.

Thanks in advance.

Attached screenshots

All Replies (16)

more options

providing the URLs of a few of those funny websites might be helpful for debugging your problem.

more options

You can check in Font Book for font issues like corrupted and duplicate fonts.

It is possible that Firefox isn't able to access the requested font and falls back to another font.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

more options

vande1 said

providing the URLs of a few of those funny websites might be helpful for debugging your problem.

one of the website's in moneybird.com

more options

yeay but how can i fix it? its annoying me. this was just normal a few days ago..

more options

Make sure you allow pages to choose their own fonts.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of my selections above"

If you use uBlock Origin make sure not to "block remote fonts".

more options

Hi Cor-el,

i have already enabled that pages can use their own font, but is still does not work.

more options

What font is Firefox using ?

I see Roboto Medium (OK for you; weight:500) for the large text and Roboto (wrong for you; weight:400) for the smaller text, so maybe try to increase the weight for the latter to 500 as a test.

more options

If i increase it to 500 it displays as normal. but how can i fix this? i have this issue on multiple websites.

more options

Weird.

Do you possibly have Roboto fonts installed on your computer as there is a fallback specified ?

more options

This issue is likely caused by a problem with locally installed Roboto fonts, so you need to check if you have locally installed Roboto fonts and uninstall these fonts and possibly install the latest version.


Found this bug report that looks similar.

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

Hi,

I have removed the roboto font and reinstalled it but i still have the same issue... is there another solution?

more options

If i open the website on Safari, the font displays normally. so its a firefox issue

more options

Does it work properly if you uninstall the Roboto fonts ?

What Roboto variants do you have ?

more options

i have the google one, but it is not only the roboto font, i also have this issue with the helvetica font. and its only on firefox on safari it diplays the websites as normal.

more options

Do sites that use Roboto work properly if you remove the local font ?

In what location are these fonts installed ? Does it make a difference if you move them to system fonts ?

more options

If i remove the local font it works properly for some reason.. but i need to font for photoshop and illustrator. The fonts are installed in the font library in my macbook