Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Sent by and reply to addresses WRONG

  • 2 replies
  • 1 has this problem
  • 214 views
  • Last reply by ValkyrieDMN

more options

I have tried to find the answer on my own, and I'm more frustrated than when I started. I've been using GMAIL since the time the only way to get an account was to be invited...long time and I've been using TBIrd for at least 15 years. I've never had this issue before and I'm baffled.

Anyway, one of my email accounts is acting up and why am I not asking GMAIL? Because, I've already determined that it's a Thunderbird issue not a GMAIL issue. Bear with me as I try to explain this clearly. I'll use G1 (the email I'm sending from) and G2 (the email it says I'm sending from) in place of the actual addresses.

please note: every time I sent a test email I always made sure the correct email address is displayed in the From: __________ Yesterday I sent an email to a friend who runs a business. Whenever I deal with these types of businesses I use G1. When she responded I noticed that it went to my G2 inbox. Hmm,that's not right. So I checked the settings in TBird for G1:

Email address is correct Reply-to-address is left blank

I send a test from G1 to G3 (my primary). It said it came from G2, hit reply and it was addressed to G2. I spent more than an hour trying to find out through Google why it might be happening. None of my search parameters came back with the right kind of answers. They all wanted to tell me how to change the reply address. While laying in bed, it dawned on me to check G1 through the gmail website in the AM.

This morning I did just that. I combed through all the settings to make sure there was no mention of G2 and there was none. I went back to TBird and looked at the settings yet again (yes, insanity is when you keep doing the same thing over and over expecting different results, LOL). While doing that I got the idea to go back to the website and send myself an email from G1. So I sent a test to G3 again. Checked it in TBird and it had the correct address in the from line, hit reply, yep it was correct, too. Darn it. As if that wasn't nuts enough, I replied to my test from G3. It went to G1. I hit reply again to go to G3, it displayed G2. DANG IT! It's gotta be a Tbird problem, not a Gmail problem.

Last night I checked the sent boxes. All the emails sent from the intended G1 were in the sent box for G1. Checked the sent box for G2, no emails. So it knows that it's FROM G1, but it's masking (or whatever) with G2, ARGH!! Help me, please, this is driving me insane.

TIA

Chosen solution

Check which smtp server your accounts are sending through, because gmail will automatically switch in the address of the gmail smtp server if you're sending from a different account, but through the gmail smtp. So, if you send a message from G1, but use G2's smtp, recipients will see the message as sent from G2, so replies will go to G2.

Tools/Account Settings, select an account in the left pane, then note Outgoing Server (SMTP) in the right pane. Each account should be sending on an smtp with the same User Name (email address) as the selected account. Edit SMTP server... to see the smtp details.

It is possible to send from a non-gmail account through a gmail smtp, without the address being switched, but you have to add the non-gmail account in gmail settings as a registered sender.

Read this answer in context 👍 2

All Replies (2)

more options

Chosen Solution

Check which smtp server your accounts are sending through, because gmail will automatically switch in the address of the gmail smtp server if you're sending from a different account, but through the gmail smtp. So, if you send a message from G1, but use G2's smtp, recipients will see the message as sent from G2, so replies will go to G2.

Tools/Account Settings, select an account in the left pane, then note Outgoing Server (SMTP) in the right pane. Each account should be sending on an smtp with the same User Name (email address) as the selected account. Edit SMTP server... to see the smtp details.

It is possible to send from a non-gmail account through a gmail smtp, without the address being switched, but you have to add the non-gmail account in gmail settings as a registered sender.

more options

Thank you! Simple fix, completely overlooked.