Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dont open Office attachments

  • 5 replies
  • 1 has this problem
  • 47 views
  • Last reply by Toad-Hall

more options

Hello

Long time dont use Thunderbird and some time ago I need to use it. And there is a problem with Office attachments as a long time ago - then problem didnt solve... Thunderbird dont open Office attachments. I have a message:

Error Word when try to open file. Try to do next actions.

  • Check permission for access to file or disk
  • Check, does it enough space or memory and etc

Same with Excel files

But others attachments Thunderbird open fast and easy - pdf, jpeg, etc. Even those Office attachments that I send to somebody. Dont open only those that I recieve.

How to solve this problem? I need to save those Office attachments on disk and only then open them. It's really annoying. Windows 7 Office 2016 Thunderbird 60.9.0 (32-bit)

Chosen solution

Thanks for images. It shows excel is opening but then throws up that error message which is not very helpful. This sounds like something to do with Microsoft and an excel protected setting. Please try this: Open Excel: Go in Excel options, trust center, settings, and untick all the options about "protected view".

Read this answer in context 👍 1

All Replies (5)

more options

You have to select the program you want to open MSWord and MSExcel documents.

I notice you are using an old version of Thunderbird released in sept 2019.

What is currently setup? Look here: Menu app icon > Options > Options > Attachments > Incoming Under content type: Look for eg: Microsoft Excel Worksheet It might help to post an image.

If you do not have MSWord or MSExcel in the list then you need to add it.

  • Right click on attachment .docx and select 'Open'
  • Select 'Open With' and choose the appropriate program or maybe you see TWINUI you can select it.
  • Select: 'do this automatically for files from now on'
  • click on OK

Helpful?

more options

Well now I have as U say (see images) .doc open normally. But xls and xlsx still dont open. It says that I dont have enough space on disk... There is about 50gb free space...

Helpful?

more options

Chosen Solution

Thanks for images. It shows excel is opening but then throws up that error message which is not very helpful. This sounds like something to do with Microsoft and an excel protected setting. Please try this: Open Excel: Go in Excel options, trust center, settings, and untick all the options about "protected view".

Helpful?

more options

FINALLY!!! Great thx!!! It is worked!

Helpful?

more options

Good to hear you are now ok.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.