Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable automatic downloads on Firefox

  • 1 reply
  • 1 has this problem
  • 3 views
  • Last reply by FredMcD

more options

I am a medical professional and use an electronic medical record website to submit electronic prescriptions. On this particular website, I keep getting automatic downloads of coupons that open up a PDF on my Mac. How do I stop the website from doing automatic downloads? I don't have this issue on other websites. In Chrome, I don't have this issue and only get the download if I specifically click on the coupon link. The website customer support said it's an issue with Firefox, not their website. How do I at least stop getting my Mac to open up downloaded PDFs automatically?

All Replies (1)

more options

Log in to the website and check your options.


Go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) and search for a good ad blocker.

I don't know if this would help.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.