Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Use paragraph format instead of Body Text by default doesn't stay unchecked when restarting Thunderbird 78.6.0

  • 11 replies
  • 1 has this problem
  • 47 views
  • Last reply by mark.mecord

more options

I really don't want paragraph mode when composing emails. Unchecked the 'Use paragraph format instead of Body Text by default' and it works until I restart Thunderbird 78.6.0.

Chosen solution

Copied the prefs.js from my laptop to the PC and updated the calendar settings (I use Google Calendar) and the setting stayed. So there was something in the original prefs.js that was either corrupt or not allowing the setting to be saved.

Read this answer in context 👍 0

All Replies (11)

more options

Possibility - Sounds like the session does not update necessary files after exiting Thunderbird. Do you use a product like CCleaner or have a similar 'clean up files' operation being performed by perhaps your anti-virus product ? If yes, then you need to make Thunderbird profile exempt from those programs or stop using them because they can clean up required files like cache, session and even passwords causing all kinds of silly issues.

more options

No, I don't use CCleaner or similar software on this PC. I also turned the Anti-Virus (and tamper) off and it still resets. I checked config and when I restart Thunderbird the key has been reset to True. Even when I manually set it to false it resets on restart. Almost ready to revert to an older version of TB and not allow updates.

more options

What OS are you using ?

more options

Windows 10 Pro 20H2

more options

Did this suddenly start when you updated from 78.5.0 to 78.6.0 ?

more options

It was a much older version, 64?

So I changed the setting and exited Thunderbird. Made a copy of the prefs.js file and relaunched. The copy has the "mail.compose.default_to_paragraph" key, the prefs.js does not. So when Thunderbird starts it is either getting a new version from somewhere else or deleting that entry.

more options

So after exiting Thunderbird, the 'prefs.js' file had this: user_pref("mail.compose.default_to_paragraph", false); but after restarting Thunderbird that 'prefs.js' file had deleted that entry.

Did you notice if Thunderbird had created a new 'prefs.js' file, in other words are there other 'prefs.js' files but with numbers in name eg: prefs-1.js, prefs-2.js etc ?

Workaround - as I think there is some weirdness abound... This next bit is an idea on how to force Thunderbird to set this option. Exit Thunderbird..... In the 'profile name ' folder where the 'prefs.js' file is located, do you see a 'user.js' file ? If no, then open 'Notepad' Enter the following - copy paste if required. user_pref("mail.compose.default_to_paragraph", false); Save file as : user.js in the 'profile name' folder, so it's in same place as the 'prefs.js' file. (If you use a Windows text editor, make sure you unhide extensions for known filetypes in Folder Options, so that the 'user.js' file isn't really called "user.js.txt". If you discover it is called 'user.js.txt' then right click on that file and select 'rename' and remove the .txt part. It will probably say are you sure blah blah it might not work etc.. say 'yes' as you do want to change it.

Then start Thunderbird.

Modified by Toad-Hall

more options

No other prefs files other than the copy I made. Already tried the user.js workaround. File is there and doesn't get modified on startup, but also doesn't have any effect on the setting. And yes, it has the .js extension. Maybe time to try the 64 bit version? Or creating a new profile and see if the problem persists?

more options

I would try a new download of win64.

Thunderbird program will be located here: C:\Program Files (x86)\Mozilla Thunderbird Delete the 'Mozilla Thunderbird' folder then empty the 'Recycle Bin' on computer.

Get a fresh download of the same version as available here on official webpage. Just choose the one for your preferred language. Choose the Windows64 bit version. https://www.thunderbird.net/en-US/thunderbird/all/

Please report back on results.

more options

Install of the 64 bit version didn't change anything. Created a new profile and the setting stays. So there is something in the profile that is not allowing that setting (and perhaps others) to work correctly. Will do a bit more troubleshooting and post what I find.

more options

Chosen Solution

Copied the prefs.js from my laptop to the PC and updated the calendar settings (I use Google Calendar) and the setting stayed. So there was something in the original prefs.js that was either corrupt or not allowing the setting to be saved.