Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How Can I Get Thunderbird To REMEMBER My Composition Settings Once I Exit & Restart Program?

  • 6 replies
  • 1 has this problem
  • 44 views
  • Last reply by cpp_progjoe

more options

I recently updated to 68.x from 61.y, and the darn program won't remember that my Composition settings are supposed to be in 'Body Text' rather than 'Paragraph' every time I restart another session (same day or another day). In other words under Tools >> Options >> General >> Composition, the Check Box "Use Paragraph Format Instead Of Body Text By Default" remains and/or is still checked when I restart Thunderbird again (NO MATTER how many times I uncheck it & leave it unchecked when exiting).

I recently updated to 68.x from 61.y, and the darn program won't remember that my Composition settings are supposed to be in 'Body Text' rather than 'Paragraph' every time I restart another session (same day or another day). In other words under Tools >> Options >> General >> Composition, the Check Box "Use Paragraph Format Instead Of Body Text By Default" remains and/or is still checked when I restart Thunderbird again (NO MATTER how many times I uncheck it & leave it unchecked when exiting).
Attached screenshots

Modified by Wayne Mery

Chosen solution

Open Tools/Options/Advanced/General/Config. editor and paste this into the Search:

mail.compose.default_to_paragraph

If the value is true, this means the box is checked in Composition, otherwise if it's false, the box is not checked. Double-click (toggle) the preference and see if the setting is retained between restarts. If it isn't, it suggests the prefs.js file in the profile is corrupted. Fixing that may or may not be simple.

http://kb.mozillazine.org/Preferences_not_saved

Read this answer in context 👍 1

All Replies (6)

more options

Works for me.

So, the setting has immediate effect, and body text is used UNTIl you restart?

Before you go to options

  • do tools > ctrl+shift+J and clear the error console
  • then attempt to change the setting

Is there anything new in the error console?

If you do Help > restart with add-ons disabled, does the setting stick?

more options

Just for added clarification: I'm trying to get it to STAY ON 'Body Text.' I can get it to temporarily go to 'Body Text' by going to Tools >> Options >> General >> Composition and unchecking the "Use Paragraph Format Instead Of Body Text By Default" Check Box. It will format all my e-mails in the 'Body Text' structure the rest of the session. However, if I restart (program/PC - whatever), the designation is back to 'Paragraph' (meaning the "Use Paragraph Format Instead Of Body Text By Default" Checkbox is CHECKED again). No matter what.


I DID clear the Error Console, and there is NOTHING in the console afterwards. Then verified the setting. It will stay correct at 'Body Text' within SAME session, but once I restart in any way, back to 'Paragraph' setting. I also did the restart WITHOUT add-ons, and it made ABSOLUTELY NO Difference. I'm shocked, because in previous versions (pre 68.x), it always worked, NOW 'Paragraph' is how it starts ALL the time??


Thanks Sincerely,

Joe W.

more options

Chosen Solution

Open Tools/Options/Advanced/General/Config. editor and paste this into the Search:

mail.compose.default_to_paragraph

If the value is true, this means the box is checked in Composition, otherwise if it's false, the box is not checked. Double-click (toggle) the preference and see if the setting is retained between restarts. If it isn't, it suggests the prefs.js file in the profile is corrupted. Fixing that may or may not be simple.

http://kb.mozillazine.org/Preferences_not_saved

more options

This was the most helpful, I guess. What I ended up doing was ACTUALLY creating a Profile (I hadn't BEFORE), then setting up my accounts again. Copying EVERY single folder from my old setup (default/unnamed 'profile'), and ALL the inerts. STILL missing some of my tags and stuff (like a few messages that were in the Trash or Junk files folders previously), but AT LEAST I have 99.99% of my old messages, and the messages by default & automatically come up as 'Body Text'. I kept my old unnamed profile (really the profile folder is what I'm referring to) just in case I find some messages I know I should HAVE - but the DEFAULT Profile is the ONLY one that comes up EVERY time now.

It was the most tedious 2.5 hours of my life, and that's saying a lot, because as a programmer I've seen some tedious coding in my life. It definitely wasn't easy like user 'sfhowes' said, but it truly was worth it NOT to continuously have to skit around changing the style EVERYTIME. STILL I have to say that ever since they updated Thunderbird to 68.x, it has been nothing but trouble!!!

Thanks Sincerely,

Joe W.

more options
more options

Wayne Mery said

Perhaps https://bugzilla.mozilla.org/show_bug.cgi?id=1489976

Which just makes me wonder (if they were having this problem LAST YEAR/early this year - AT LEAST on Mac), why in the heck did the whole thing take so long to happen (at least for me) on Windows. Better yet, since it had WORKED up until now, until version 68.x, why haven't they fixed this issue YET. It automatically updates itself (by my count according to 'Update History' within the Options Tab 4 times previous to Version 68), and just now, under Version 68 it pops up. They have all these fixes they have created over all these months, and they haven't even fixed this problem yet - one that seems to have been sort of semi-fixed by creating a new profile (JUST a profile period for me). That's simply ridiculous!!!!


Thanks Sincerely,

Joe W.