Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't get to my old Firefox bookmarks and history

  • 8 replies
  • 1 has this problem
  • 22 views
  • Last reply by FredMcD

more options

I can't get to my old Firefox bookmarks and history

All Replies (8)

more options

What happened? A crash? System reset? . . .

What about the rest of your profile? Settings, bookmarks, history, passwords . . . .


Look on your desktop. Do you see a folder called; Old Firefox? Look inside. Look for the folder with the latest creation date.

https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible

Helpful?

more options

Helpful?

more options

FredMcD . Thanks for your suggestions, but all I can say is that I was, until 2-3 days ago, using an old version of Firefox: 55.0.3, from Sept 22, 2017. But it then stopped. I simply cannot open it. The link in my dock now does nothing at all. For all practical purposes, it stopped existing. . Most of what you have provided is activity that I do not understand. I apologize for being rather illiterate in this matter, despite having been online in general for nearly 21 years (starting Jan, 2000). . I have no idea what to do. As of now, I am almost of a mind to just forget about Firefox altogether, and treat it as a thing of the past. If what I had been using was ended - discontinued - destroyed - by Mozilla/Firefox, with absolutely no warning, no notice that it was being ended, then I feel like I have no use for Firefox (and Mozilla) at all. . If you know of a way that some as uninformed as I can wade his way through things, I would appreciate the help. If you can email me, I am at: billfinzel at yahoo dot com.

Helpful?

more options

I called for more help.

Helpful?

more options

Thanks!

Helpful?

more options

Firefox 69 may have created a new xxxxxxxx.default-release profile.

Once you have Firefox 69 running, you might consider to update to the current release (84.0.1).


You can copy certain files with Firefox closed to the current profile folder to transfer or recover personal data. Note that best is to avoid copying a full profile folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


  • bookmarks and history: places.sqlite
  • favicons: favicons.sqlite
  • bookmark backups: compressed .jsonlz4 JSON backups in the bookmarkbackups folder
  • cookies.sqlite for the Cookies
  • formhistory.sqlite for saved autocomplete Form Data
  • logins.json (encrypted logins;32+) and key4.db (decryption key;58+) for Passwords saved in the Password Manager
    key3.db support ended in 73+; to use key3.db in 58-72, make sure to remove key4.db
  • cert9.db (58+) for (intermediate) certificates stored in the Certificate Manager
  • persdict.dat for words added to the spell checker dictionary
  • permissions.sqlite for Permissions and possibly content-prefs.sqlite for other website specific data (Site Preferences)
  • sessionstore.jsonlz4 for open tabs and pinned tabs (see also the sessionstore-backups folder)

Helpful?

more options

Hello cor-el . The version that stopped being available, where I have bookmarks, history, toolbar, & etc is 55.0.3 . I was able to use it until about 2 days ago. I can no longer access it. I really do not relish "starting over" with years of content. The icon is still on my dock, but it won't open. . Bill

Helpful?

more options

Bill said

. . . I can no longer access it . . .

Please explain the problem in detail. What happens? What is/are the exact error message(s) ?


Have you tried reinstalling the version you want?


Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.