Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

cookies and website data always deleted

  • 6 replies
  • 1 has this problem
  • 18 views
  • Last reply by FredMcD

more options

Firefox deletes cookies and website data when i exit the browser, although this function is deactivated. everytime i end firefox v 84.0 (64-Bit) and start new cookies and website datas are deleted. no matter what is set.

see picture, the function itself is set to off:

Attached screenshots

Chosen solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Read this answer in context 👍 1

All Replies (6)

more options

Profile data can be removed or not recorded in several ways;

  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings; (In the address bar, type about:preferences#privacy<enter>)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers
    Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.

Helpful?

more options

I normally run the browser in normal mode, after a fresh install windows 10 3 month ago, i delayed activate firefox sync. it is possible that since this the error is available.but i cannot say this for sure 100%. i do not use disk cleaners, there was no malware detected on the system. also after a scan with with win defender no virusses detected. so unfortunately the 4 points didnt help.

Helpful?

more options

Some anti-virus don't detect malware.

Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed free to use malware scanners. Each works differently. If one program misses something, another may pick it up.

Helpful?

more options

Chosen Solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Helpful?

more options

Thank you very, very much FredMcD. For what kind of reason this option was set to on i don´t really know, but this does fix it. option delete cookies when closing set to off now. all is working like before some day.

have nice and warm christmas days with you beloved ones.

alco nice christmas to alll other users.

thanks a lot

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.