Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps changing my default search engine preference back to Google

  • 4 replies
  • 1 has this problem
  • 52 views
  • Last reply by cor-el

more options

Firefox keeps changing my default search engine from DuckDuckGo back to Google on restart.

I'm on Mac High Sierra.

I have changed my choice for default search engine and deleted all other browsers in search shortcuts a couple dozen times, and I reinstalled Firefox twice. Nothing helped.

Getting really really frustrated . . .

All Replies (4)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Google “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

more options

Thanks Fred, but I don't see anything in extensions, Google or otherwise (although I see some that they recommend.) And I don't see anything called "Programs Folder" in my application folder. Am I missing something?

more options

FredMcD said

Mac: Open the Applications folder.
more options

You can rename/remove search.json.mozlz4 in the Firefox profile folder with Firefox closed to rebuild the search engines registry.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Firefox will rebuild search.json.mozlz4 from the builtin search engines.