Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get obsolete info out of a typing box?

  • 13 replies
  • 1 has this problem
  • 50 views
  • Last reply by sideburns

more options

Recently, I had to change my username at my bank's website because somebody was trying a brute force attack on my password. Now, the site still shows my old username, although I've gone to my Saved Logons in Preference and removed all logons for that site except for the correct one. I have to delete the old username from the typing box every time I log in there, after which I can select the correct (and only) saved username/password.

Chosen solution

This issue went away on its own, but came back. This time, I removed all cookies for the site (three domains) and tried logging in. After entering a verification code the bank sent me, it seems to be working right. I just wish I knew how to keep it from coming back again.

Read this answer in context 👍 0

All Replies (13)

more options

That could be the form filler built into Firefox. Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press Shift > Delete Repeat as needed.

Do any of these links help you? https://support.mozilla.org/en-US/kb/control-whether-firefox-automatically-fills-forms

https://support.mozilla.org/en-US/search?w=1&q=autofill

more options

Your first suggestion works, but Firefox keeps going back to the old logon if I reload the page, or close it and navigate to it again. Neither of your other two suggestions did anything useful. Thanx for trying, though.

more options

Make sure to check the Password Manager. Also, check Lockwise. about:logins

more options

What do you see if you right-click the empty username field and look at "Fill Login" ?

It is possible that the website fills this username automatically, possibly via a cookie.

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear
more options

FredMcD said

Make sure to check the Password Manager. Also, check Lockwise. about:logins

I have no idea what Lockwise is, and I've already cleared out every login for that site except the correct one. As for Password Manager, I don't use it.

more options

cor-el said

What do you see if you right-click the empty username field and look at "Fill Login" ? It offers me the one, correct login. "Remove the Cookies" for websites that cause problems:
  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

...and how do I look at the cookies and delete specific ones?

more options

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

more options

FredMcD said

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings. Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Do I have to restart Firefox as well? If so, I'll let you know if it works later.

more options

Yes. When Firefox closes, it can be set to clean itself.

more options

I followed the instructions I quoted, went to the bank's site and cleared the old username from the box, then closed Firefox. When I reopened it and went to the bank's site, the old username was back again.

more options

Chosen Solution

This issue went away on its own, but came back. This time, I removed all cookies for the site (three domains) and tried logging in. After entering a verification code the bank sent me, it seems to be working right. I just wish I knew how to keep it from coming back again.

more options

Did you set the about:preferences#privacy options as I said?

more options

No, I did exactly what I said I did and nothing more. Everything else is working fine, and I'm not making any more changes than I have to.