Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot login Amazon with Firefox

  • 5 replies
  • 1 has this problem
  • Last reply by FredMcD

more options

I am switching from Safari to Firefox. My login to Amazon no longer works, I get the following message. Any suggestion for how to fix this? Thanks.

File not found

Firefox can’t find the file at moz-extension://1119a7fa-a36f-3a4d-869a-ae79f68cb468/

   Check the file name for capitalization or other typing errors.
   Check to see if the file was moved, renamed or deleted.

Chosen solution

It might be the link is no longer good. Try starting from the main page.

Read this answer in context 👍 1

All Replies (5)

more options

Chosen Solution

It might be the link is no longer good. Try starting from the main page.


more options

Hi Sue, this part


refers to one of your add-ons. That "unique id" is personal to your Firefox installation, so there's no way for us to look up exactly what it is.

I'm puzzled why it is even coming up when you are accessing Amazon. So, two questions:

(1) Could you describe the sequence of events leading up to the error?

(2) Could you look up the name of the extension on the About Debugging page? Here's how:

Type or paste about:debugging in the address bar and press Return to load that internal page.

Click This Firefox in the left column.

Use Find (Command+F) to look for part of the unique id above (for example, 1119).

Which extension is that?


more options

Thank you !

You are right. After just entering the main page as the address, it worked.

I didn't know what to make out of the error message, particularly since from Safari, with the exact same URL (from a password vault), I had no problems.

I appreciate the quick help.


more options

Thanks, jscher2000.

Fred McD's suggestion solved the problem. I had a long URL in my password vault, probably saved for the login screen. It worked with Safari. I changed that to just and now it works....

I will save your answer for any other time when I encounter a similar problem.


more options

Glad to help. Safe Surfing.


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.