Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Accessing the Amazon website

  • 1 reply
  • 1 has this problem
  • 3 views
  • Last reply by jscher2000

more options

I have been having difficulty connecting to the Amazon.com website through Firefox. Is this an amazon problem or a firefox issue? Here is the error I keep getting:

Secure Connection Failed

An error occurred during a connection to www.amazon.com. PR_END_OF_FILE_ERROR

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.

thx

All Replies (1)

more options

This particular code isn't mentioned in this article: Secure connection failed and Firefox did not connect.

Could I suggest trying "the usual" to see whether some previously saved data is causing the problem:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Web Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. Note: you only need to clear Web Cache and not all cookies and site data.

(2) Remove the site's cookies

While viewing a page on the site -- save any pending work first -- click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

If you cannot access cookies that way due to the connection problem, try this way:

Open the Preferences page --

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security and then on the right side, in the Cookies and Site Data section, find the Manage Data button. (Sometimes it takes a few moments before this button is enabled while Firefox searches the saved data.)

Click the Manage Data button and use the little search box to find amazon. Then highlight the Amazon rows and click Remove Selected, then click Save Changes, then confirm the deletion.

Then finally, try reloading the page. Does that help?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.