Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird 78.4.3 font size

  • 16 replies
  • 3 have this problem
  • 799 views
  • Last reply by t8769

more options

I have been trying to figure out a way to change the font sizes in Thunderbird 78.4.3. None of the "help" works. Font changing extensions are out of date. Help threads point to menu items that aren't there. Can't even find the "config.editor". My eyes just can't handle the small fonts anymore.What can I do?

Captain Quack.

All Replies (16)

more options

In version 78*:

  • Menu app icon (3 horizontal lines) > Options (If using MAC it's 'Preferences')
  • Select 'General' - top of left pane
  • Scroll down to the very bottom (OR type: Config into the top right 'find in options' search)
  • click on 'Config Editor' button to open 'about:config'

It will say be careful :)

  • In search type: pixels
  • Look for this line: layout.css.devPixelsPerPx
  • Double left click on that line to open the 'Enter string Value' box so you can edit the Value.

The default value will be -1.0

  • Enter a new number eg: 1.25 or 1.5 or 2.0 or 2.2
  • click on OK

the effect is immediate, so you can modify that number until it looks ok for you.

more options

If image in this forum question looks too small, click on the image to enlarge it.

more options

sorry. no config at the bottom of the page under those directions. just HTML Style at the bottom of the general page. entering config in the search box just brings up configure connection and configure offline.

Captain Quack.

more options

'HTML Style' is not under 'General' It is under 'Composition'. so you are not looking in the correct place. So I can assume you did not select 'General' and then scroll to the bottom, which is shown in th first image I posted.

Now I see what you did. You did this - (OR type: Config into the top right 'find in options' search) So you got a 'Search' result. In which case 'Config Editor' appears half way down on the right side.

I've added an image below to help.

more options

I apologize. I did have the wrong area. I found config editor and did as you suggested. that did the trick! as soon as I realized I didn't need the - in front of the number things worked out right and 2.25 is the best size for me. now I just have to remember how to do this next time I have to reinstall lol. thank you for your help even when I was being a bone head.

Captain Quack.

more options

Unfortunately, this is not working for me.

I am using a MacBook with an attached second monitor. Both screens with different in dpi / pixels. Changing the layout.css.devPixelsPerPx does affect the sizes – but very differently on each screen.

Therefore I need to stick with the (way too small) default font size. 

So, i am asking the question again: Why is the font setting too small in the first place? Obviously, people want to fix that. But why do we need to get a useful font-size by applying this hack?

Sorry, this is certainly not a rant – I am just wondering. And I think, it should be fixed in the shipped version of Thunderbird.

more options

hello97 said

Unfortunately, this is not working for me. I am using a MacBook with an attached second monitor. Both screens with different in dpi / pixels. Changing the layout.css.devPixelsPerPx does affect the sizes – but very differently on each screen. Therefore I need to stick with the (way too small) default font size.  So, i am asking the question again: Why is the font setting too small in the first place? Obviously, people want to fix that. But why do we need to get a useful font-size by applying this hack? Sorry, this is certainly not a rant – I am just wondering. And I think, it should be fixed in the shipped version of Thunderbird.


After looking into this, I came up with a solution that works for me. The task was, to make the UI readable (bigger font-sizes) on multiple screens with different sizes.

I opened the 'Config Editor' and set toolkit.legacyUserProfileCustomizations.stylesheets to true In the Thunderbirds profiles folder "xxxxxxx.default" I created the folder "chrome" inside that folder I put "userChrome.css" with following contents: (...)

I put it to github to make it easy accessible: "github.com/mjut/biggerthunderbird"

This is still something, I consider a "hack" and shouldn't be necessary in the first place. But I like the results! Thunderbird is looking a lot better now. =)

Modified by mjut

more options

It looks perfectly ok to me out of the box. I'm using Windows 10 OS and Display resolution 1920 x 1080.

But not all computers have the same screen resolution and not all people have the same eyesight. As you have seen first hand, the dpi setting on computer/monitor screen will effect what you see, hence the need to include a means of being able to alter Thunderbird so it can be adjusted to accomodate all those variations.

more options

HELP ! I was grateful to Toad-Hall for his contribution dated 14 Nov 2020 regarding Font sizes in Thunderbird. His instructions worked OK and I did a few iterations to try and get an optimum result. HOWEVER , on the last of my iterations , having clicked the Config Editor to open 'about:config' and the warning 'Here be dragons ! ' , I entered 'pixels' into the search type , found the line : layout.css.devPixelsPerPx and entered 2.0 where before I had entered 1.5 and , of course , the effect was immediate. LARGE font screen ! I went through the procedure again to change back to 1.5 setting BUT the screen lettering was far TOO big to allow me to get down to below the 'about : config' stage and allow me to get back to searching for 'pixels' and getting to the line to open the 'Enter string value' box so that I could enter 1.5 and get back to normality !

All I have now is Thunderbird with massive text and no apparent way of changing it !

Your help would be most welcome !

more options

re :BUT the screen lettering was far TOO big to allow me to get down to below the 'about : config' stage

I see what you mean :) I made the window of Thunderbird as large as possible - as wide and as high as my screen would allow. However, my screen is 28inch.

Then clicked on 'Config Editor' I now used the bottom right corner to drag the 'about:config' window as wide and as long as possible so the 'I accept the risk' became just visible and now I had access to chnage back to eg: 1.5


If this really is not possible; perhaps your screen is not as big as mine. There is another way by editing the 'prefs.js' file. In Thunderbird Help > Troubleshooting Information Under 'Application Basics' section about 8th in list is 'Profile Folder' - click on 'Open Folder' A new window opens showing contents of your profile name folder.

Exit Thunderbird now - this is important.

Locate this file: prefs.js As you do not want to mess up this file and generally you do not edit it; please make a copy of the 'prefs.js' file and put it on desktop as a temp backup. If all goes well you can delete it later.

Now open the original 'prefs.js' file using a text editor program like 'Notepad'. Use 'Edit> Find' - Find what: type pixels to Locate this line :

  • user_pref("layout.css.devPixelsPerPx", "2.0");

Edit that line - the number - so it looks like this:

  • user_pref("layout.css.devPixelsPerPx", "1.5");

Then File > Save close window

Start Thunderbird.

more options

Hi Toad Hall Glad to hear from you. This all a bit alaming for me. I am not a 'geek' , just an above average user of things like Excel and Word ! I have got your instructions but am unsure EXACTLY what to do to get Notepad to be able to open the 'prefs.js' file. Can you tell me , step by step , please ?

more options

I cannot visualise getting the line 'user_pref("layout.css.devPixelsPerPx", "2.0");' into NotePad and and activating the change ! I don't want to screw it up ! Better to ask ! But a million thanks thanks so far !!

more options

re :I have got your instructions but am unsure EXACTLY what to do to get Notepad to be able to open the 'prefs.js' file. Can you tell me , step by step , please ?

Right click on the 'prefs.js' file and select 'Open with' and choose 'Notepad' and click on OK. See image below as guide.

All the information currently in the 'prefs.js' file will be auto shown.

each line will start with 'user_pref' Use the menu to locate info as it is quicker click on 'Edit' and select 'Find' a small window opens : Find what: type pixels click on 'Find Next' button to locate the desired line

  • user_pref("layout.css.devPixelsPerPx", "2.0");

Edit that line - just the 2.0 number to 1.5 number - so it looks like this:

  • user_pref("layout.css.devPixelsPerPx", "1.5");

Then click on 'File' and select 'Save' close window using top right X

Modified by Toad-Hall

more options

BINGO ! Well done Toad Hall ! It is back to manageable preportions ! It is all still a bit on the large side but much better than the miniscule font size that was there before and which I had to use the Paragraph Headings options to get it readable. Thunderbird has deteriorated over the years that I have ued it. I was preparing to change back to Virgin Media as my email provider ( is that the correct term ) while I was wating for you to get back to me rather than have Thunderbird as the client on a day to day basis. My only stumbling block was that I did not know how to export my Address Book from Thunderbird to VirginMedia ! I could not find any buttons for importing or exporting ! However , you were pretty quick to resolve my issue so I have to thank you very much once again for that. Very impressive ! But I am still mulling over whether to ditch Thunderbird as it leaves a lot to be desired. Best regards

Terry D.

more options

hello97 said

I opened the 'Config Editor' and set toolkit.legacyUserProfileCustomizations.stylesheets to true In the Thunderbirds profiles folder "xxxxxxx.default" I created the folder "chrome" inside that folder I put "userChrome.css" with following contents: (...)

THANK YOU! I was about to pull my hair out trying to find something that works!

The PixelsPerPx just makes it look weird - it changes everything to make room for bigger text, but the text don't change (see attached picture).

I honestly don't understand why the devs 1. make the default so useless 2. makes it so difficult to change it to something useful 3. when users HAVE found a way to make it useful, the devs disables that option by default (thank God it could be enabled again)

more options

Win10 instructions re: How to increase generic Font Size as another option to suggestion by sfhowes Then if required you can increase the overall font size from within Thunderbird by using the following method.

Menu app icon > Options > General Scroll down to the very bottom click on 'Config Editor' button to open 'about:config' It will say be careful :)


In search type: pixels Look for this line: layout.css.devPixelsPerPx Double left click on that line to open the 'Enter string Value' box so you can edit the Value. The default value will be a negative number: -1.0

Enter a new positive number eg: 1.25 or 1.5 or 2.0 or 2.2 click on OK the effect is immediate, so you can modify that number until it looks ok for you.

I've included an image as a guide.

Modified by t8769