Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Incompatible plugins after upgrading to newer versions.

  • 10 replies
  • 1 has this problem
  • 51 views
  • Last reply by Toad-Hall

more options

Hi folks. I am quite angry. Again. I was not aware enough and allowed to install newest Thunderbird version. I realized after restart that only ONE of my plugins works. I am quite addicted on some of them. THIS happened at least 2nd time... Now i have to pray, that authors will modify his plugins. I am quite sure that i am not alone. Best of all: I immediately tried to downgrade back to previous version, but that version refuses to run, because it detected that newer version already modified something in system. 1)Is there some trick how to cheat that situation? I used standard approach: backed up my profile data, uninstalled new version and installed last working version. 2)Is there any possibility to convince authors to add this feature?: BEFORE install of newer version will installer check which plugins (and other consequences) will be nonfunctional an ask user if he really want to proceed? It should be simple, because it offers identical functionality AFTER install. But in that moment is already all crippled and there is no way back. Martin

Chosen solution

What add-ons were you using? I could check to see what's available or whether a newer version has been created.

re: going back to a previous version. Ever since version 68 came out there has been a dedicated profile per version. https://support.mozilla.org/en-US/kb/dedicated-profile-thunderbird-installation

Thunderbird 78 made even more changes eg: the address books used to use the format .mab and now those files have been reformatted as sqlite files.

There is a method to go back but you would need to follow very specific instructions.

So using version 78 do the following. Need to set updates to ask, change the address book, uninstall, then download old and reinstall, but do not auto start. Then use command line to force a backwards compatibily allowance.

  • Menu app icon > Options > General
  • Scroll down to 'Updates' section
  • select 'check for updates, but let me choose whether to install them'


To add also those email addresses back follow below steps: In Thunderbird

  • Help >Troubleshooting Information.

Under Application Basics section about 8 down in list see 'Profile Folder'.

  • Click on 'Open Folder'

A new window opens showing the contents of your profile name folder.

  • Exit Thunderbird

In the profile name folder - you will find the old address book files with extension .mab.bak - those files (abook and history) you need to:

  • -rename them to .mab (so remove the .bak part) eg: 'abook.mab.bak' becomes 'abook.mab'
  • -rename abook.sqlite and history.sqlite by adding .bak to the name. eg: abook.sqlite.bak
  • Do same for any other address books you created.


Now uninstall Thunderbird program. You could just delete the Mozilla Thunderbird folder from here:

  • C:\ Program Files (x86)\Mozilla Thunderbird
  • then empty the computer 'Recycle Bin'

Then get download from here:

Run the downloaded .exe file to install. On the last step of the installation do NOT select to start TB.

You will need to run a command to allow you to downgrade.

Windows OS:

  • In search type : Run
  • Select the 'Run' app
  • Type: thunderbird.exe -P --allow-downgrade

note there is a space before and after -P

  • click on OK

Profile Manager starts select the desired profile name click on 'Start Thunderbird'.

Read this answer in context 👍 1

All Replies (10)

more options

Chosen Solution

What add-ons were you using? I could check to see what's available or whether a newer version has been created.

re: going back to a previous version. Ever since version 68 came out there has been a dedicated profile per version. https://support.mozilla.org/en-US/kb/dedicated-profile-thunderbird-installation

Thunderbird 78 made even more changes eg: the address books used to use the format .mab and now those files have been reformatted as sqlite files.

There is a method to go back but you would need to follow very specific instructions.

So using version 78 do the following. Need to set updates to ask, change the address book, uninstall, then download old and reinstall, but do not auto start. Then use command line to force a backwards compatibily allowance.

  • Menu app icon > Options > General
  • Scroll down to 'Updates' section
  • select 'check for updates, but let me choose whether to install them'


To add also those email addresses back follow below steps: In Thunderbird

  • Help >Troubleshooting Information.

Under Application Basics section about 8 down in list see 'Profile Folder'.

  • Click on 'Open Folder'

A new window opens showing the contents of your profile name folder.

  • Exit Thunderbird

In the profile name folder - you will find the old address book files with extension .mab.bak - those files (abook and history) you need to:

  • -rename them to .mab (so remove the .bak part) eg: 'abook.mab.bak' becomes 'abook.mab'
  • -rename abook.sqlite and history.sqlite by adding .bak to the name. eg: abook.sqlite.bak
  • Do same for any other address books you created.


Now uninstall Thunderbird program. You could just delete the Mozilla Thunderbird folder from here:

  • C:\ Program Files (x86)\Mozilla Thunderbird
  • then empty the computer 'Recycle Bin'

Then get download from here:

Run the downloaded .exe file to install. On the last step of the installation do NOT select to start TB.

You will need to run a command to allow you to downgrade.

Windows OS:

  • In search type : Run
  • Select the 'Run' app
  • Type: thunderbird.exe -P --allow-downgrade

note there is a space before and after -P

  • click on OK

Profile Manager starts select the desired profile name click on 'Start Thunderbird'.

Helpful?

more options

Hi Toad. Thanks a lot for Your support. Sure, i tried to check if there are any upgrades plugins there, but except of one(unimportant) no progress. Authors do rebuilding their soft slowly, so you have to wait a lot (and sometime to pay for it) (if you are the lucky and plugin will not cancelled definitively) I'm just studying your procedure... I already set updates to ask, uninstalled NEW and installed OLD (68.12.1). But i did not the magic around address book and started TB68 (fail) Q1: Should i uninstall 68 and install 7x to complete magic with address book? I guess that not, i found those *.mab.bak and also sqlite files ...so i can do rename them. Do You agree? Q2:I already started TB68... is still OK to rename those MAB and SQLITE files and run command line ? I ask to be sure ...and not to damage it even more...

And what do You think about request for checking plugins etc BEFORE install..?

Helpful?

more options

Hi Toad-Hall.

Helpful?

more options

I wrote a long reply ...but .. All those moments will be lost in time, like tears in rain. So again.. Plugins: I tested if there are some upgraded, but except of one all remained disabled. As common expectation could be seen that authors will need some more time to rebuild their plugins (and eventually you have to pay for it in some cases). (If you are lucky one and your beloved plugin remain unsupported). I have some questions. I already did before: Set actualization to ask, uninstalled, installed 68.12.1 and run. So i skipped magic with address book. Q1:I found those mab.bak and sqlite files. Can i rename them in this state without need of installing and uninstalling TB7x again? Q2:I already started downgraded TB68...did it harmed ? Or i can proceed with command line? I am asking to be sure and do not damage something more.

To my 2nd problem: How do You see it with request to check compatibility BEFORE installing new version? With regards, Martin

Helpful?

more options

I, too, am irritated by the changes to 78 - there are addons that I really like to use and the authors are so fed up with TB moving the goalposts that they have thrown in the towel. I don't blame them.

The other day, I spent a few hours rebuilding my v68 TB profile due to corruption, and had just got it back and running to my liking on v68. Now I find that it has automatically updated to v78 (foolishly, I wasn't expecting that as I thought it wasn't doing major updates automatically). Then I reinstalled v68 but had the newer version error message. I didn't know about the allow downgrade option (it would be helpful to mention it in the error message box). So I just spent another happy hour downgrading manually - fortunately I'm clued up enough to know what to copy over from the updated profile and all seems to be working ok.

(the addons I rely on are account colours and tab toolbar - I can't understand that TB doesn't allow colour coding of accounts - If I didn't rely so heavily on tags, I'd be moving to another client such as Airmail to harmonise with my mobile devices).

Helpful?

more options

The frequently-updated list of 78 add-ons is here:

https://cleidigh.github.io/ThunderKdB/xall/extension-list-tbmx.html

Account Colors will probably not be updated, but BorderColors D is similar.

Perhaps you meant Tag Toolbar? There is a version for 78.

Helpful?

more options

Thanks, but Border Colours states that it for the new message window (ie compose) and not for the main message list, the latter is what I want. The Tag Toolbar/Popup version for 78 is very different and I found it nothing like as convenient.

Helpful?

more options

Irrespectively of fact that it maybe exists somewhere in this universe a plugin which tends to be similar to currently used...i definitely do not want to spend rest of my time by searching for it. I would prefer to use my beloved precious plugin even for price of unactual TB. Yes, such people exists. At least for a while until someone adapts his plugin. It can last a months. And therefore i would like to have fair information: When you allow me to do THIS, you have to count that it will break THAT. BTW: Tab toolbar is for me a major reason why NOT to upgrade to TB7x...

Helpful?

more options

Funny, my first attempt to send a reply here (was not available for at least 15 min and therefore i wrote new) appeared today... I followed Toad suggested procedure (modified) and been successful. At first moment i was stressed, that TB had no plugins, but then i selected in plugin actualization window 'search for new versions' and my beloved precious rin..plugins appeared (after restart). Thanks a lot for help, Toad. BTW to auditorium: my crucial plugins are Send Later https://blog.kamens.us/send-later/ and QuickFolders https://quickfolders.org/index.html They are already working on new version, but you know...

Additionally: Do You think that 1)my case is so rare that it is not necessary to prepare and publish this for me clear downgrade procedure for public? 2)or am i such incompetent person , who is not able to find this procedure in FAQ? Have a nice day :) Martin

Helpful?

more options

re :The Tag Toolbar It was forced to change because the ability to add a new toolbar API was removed. I did create a bug report but the people in charge were not sympathetic about the request. https://bugzilla.mozilla.org/show_bug.cgi?id=1658559

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.