Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird can't open Twitter links.

  • 19 replies
  • 3 have this problem
  • 382 views
  • Last reply by pkpiggott47

more options

Thunderbird will not open a Twitter link emailed to my Thunderbird. It worked just fine till a few months ago. Gives a msg 'this file does not have an app associated with it. With a right click I can 'copy link location' and paste it into Firefox address line.

Chosen solution

so no resolution to this? just copy/paste?

Read this answer in context 👍 0

All Replies (19)

more options

could you copy link location and paste it into notepad. Does the pasted link start with HTTPS? or something else like Twitter?

more options

Thank you for the response. Yes, the link pasted into Notepad starts with HTTPS. Saved that into a text file. Thunderbird continues to reject an attempt to open Twitter as having 'no app associated to perform this action'. I can copy the link location, paste it into Firefox and that works. Until a few months ago, emailed Twitter links worked directly from Thunderbird but no more.

more options

re: no app associated to perform this action' That is a message from your computer.

Twitter has decided to change/in process of changing the API and therefore it has been removed from Thunderbird.

Menu app icon/File > New > Chat account Twitter is no longer in the list. It was removed a few versions ago.

The app facility in Thunderbird no longer exists and it sounds like you do not have an alternative on your computer.

But in a nutshell, it is no longer supported.

I did located this information which may be of help

Modified by Toad-Hall

more options

Thank you, this explains the problem but doesn't solve it. I'm left with the nuisance. Can you recommend a work-around? Perhaps changing email app for one that will handle Twitter?

more options

Chosen Solution

so no resolution to this? just copy/paste?

more options

julia.royce said

so no resolution to this? just copy/paste?

Yes, just copy/paste. Not pleased but life goes on and this is just a nuisance.

more options

You could install the twitter app from the windows store... this does appear to be what this is all about, get everyone on the twitter app. I installed it just to stop the messing around months ago because I can find nothing even hidden in the registry that points the HTTPS: links for twitter to a local app. So I am assuming without any further information that it is being redirected back somehow from the Twitter web site. The links I have looked at all go to a redirect URL at twitter.

more options

re :so no resolution to this? just copy/paste? You can copy paste. Your computer has no app associated with twitter, that's why you get the computer error message. I provided the link on how to get twitter on Windows 10. Have you followed the advise?

more options

Ok Mr. Hall. I have installed MS Twitter app, signed in as you suggest. Thunderbird still does not see the MS app and stonewalls. How do I make Thunderbird see the Twitter app?

more options

You don't need to install the Twitter app, and the API change has nothing to do with why Twitter links won't automatically launch in Firefox after clicking on them in Thunderbird.

I'm running Thunderbird 78.4.3 (32-bit) on Windows 10 Pro 64 bit version 20H2 (OS build 19042.630).

When a Twitter https link is emailed to me, I click on it in Thunderbird, and Firefox 82.0.3 (64 bit edition) loads the link automatically as it should.

I don't have Twitter app installed, and this API nonsense is a red herring and completely unrelated to the issue you're having. No one here is using Chat.

more options

julia.royce said

so no resolution to this? just copy/paste?

This is not a real solution. It's a kludge.

Modified by ArrowFlynn

more options

Toad-Hall said

Twitter has decided to change/in process of changing the API and therefore it has been removed from Thunderbird.

That is completely unrelated to the problem the user is describing.

I'm not having any problems getting Firefox to automatically launch Twitter links after clicking on them in Thunderbird.

Modified by ArrowFlynn

more options

mel.richardson said

Thunderbird will not open a Twitter link emailed to my Thunderbird. It worked just fine till a few months ago. Gives a msg 'this file does not have an app associated with it. With a right click I can 'copy link location' and paste it into Firefox address line.

My mother encountered the same issue today. I had to remotely connect to her computer to fix the issue for her. Here's the fix:

1. In Thunderbird 78.4.3, navigate to Tools-->Options. Scroll all the way down to the "Config Editor" button. Click it.

2. Select "I Accept The Risk".

3. Search for "network.protocol-handler.warn-external.https" without the quotation marks.

The Twitter links that I'm sent are all https://

4. If network.protocol-handler.warn-external.https is set to false, right click on it, and select "Toggle", so that the value shows "true".

5. Exit Thunderbird. Run Thunderbird again.

6. Now click on the https://twitter link that you were emailed in Thunderbird.

7. A dialogue box will appear asking you to select the app. Presumably Firefox is already selected. The association doesn't work and needs to be fixed.

Select "Choose another application", and select the "Choose" button.

8. Locate firefox.exe on your computer. The location for me, since I'm running a 64 bit edition is C:\Program Files\Mozilla Firefox\firefox.exe

If you're running the 32 bit edition of Firefox, the file location might be found under C:\Program Files (x86)\Mozilla Firefox

Regardless, select the firefox executable file.

9. Check the box for "Remeber my choice for https links".

10. Click "Open Link"

11. Firefox should then launch your twitter link.

12. Go back into Thunderbird. Repeat steps 1 to 5, except this time change network.protocol-handler.warn-external.https to false in step 4.

13. That should fix the problem. If it doesn't, try going through the information listed at https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working starting with "Problems with received or saved mails" and work your way down.

Good luck!

Modified by ArrowFlynn

more options

Thank You ArrowFlynn!

The below quoted reply is the answer to fix this problem. It has nothingto do with anything Twitter has done or is doing.

Not sure why this changed all the sudden in Thunderbird though.

Question for ArrowFlynn: Why do you say to go back in and set that "network.protocol-handler.warn-external.https" to false again after setting the default? Is that just to avoid any problems with it getting changed again?

Thanks again for your answer to this problem!

ArrowFlynn said

mel.richardson said

Thunderbird will not open a Twitter link emailed to my Thunderbird. It worked just fine till a few months ago. Gives a msg 'this file does not have an app associated with it. With a right click I can 'copy link location' and paste it into Firefox address line.

My mother encountered the same issue today. I had to remotely connect to her computer to fix the issue for her. Here's the fix:

1. In Thunderbird 78.4.3, navigate to Tools-->Options. Scroll all the way down to the "Config Editor" button. Click it.

2. Select "I Accept The Risk".

3. Search for "network.protocol-handler.warn-external.https" without the quotation marks.

The Twitter links that I'm sent are all https://

4. If network.protocol-handler.warn-external.https is set to false, right click on it, and select "Toggle", so that the value shows "true".

5. Exit Thunderbird. Run Thunderbird again.

6. Now click on the https://twitter link that you were emailed in Thunderbird.

7. A dialogue box will appear asking you to select the app. Presumably Firefox is already selected. The association doesn't work and needs to be fixed.

Select "Choose another application", and select the "Choose" button.

8. Locate firefox.exe on your computer. The location for me, since I'm running a 64 bit edition is C:\Program Files\Mozilla Firefox\firefox.exe

If you're running the 32 bit edition of Firefox, the file location might be found under C:\Program Files (x86)\Mozilla Firefox

Regardless, select the firefox executable file.

9. Check the box for "Remeber my choice for https links".

10. Click "Open Link"

11. Firefox should then launch your twitter link.

12. Go back into Thunderbird. Repeat steps 1 to 5, except this time change network.protocol-handler.warn-external.https to false in step 4.

13. That should fix the problem. If it doesn't, try going through the information listed at https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working starting with "Problems with received or saved mails" and work your way down.

Good luck!

more options

TB = Thunderbird . FF = Firefox.

here is a solution: in this solution you MUST load two addons/extensions. (1) obtain this TB addon/extension: BrowseInTab. after this, when you will right-click on link, it will give new option "Open Link in New Tab". (2) obtain this FF addon/extension: get uBlock-Origin from Firefox addon-site, and then manually add/load this addon inside the TB, this addon protects Thunderbird (and you) from being abused by Advertisement based abuses, computing+data resource theft, computer overheating, etc.

in TB, goto main-menu > Preferences/Options/Settings > Privacy > scroll-down to "Web Content" section: you can enable/select "Accept Cookies From Sites", then all TRACKING/MONITORING/ID,etc all type of cookies from wanted & unwanted sites will also be stored inside Thunderbird, so, its not safe to enable/select it : i suggest to keep it disabled/unselected. when above option is disabled, then you have to add COOKIE-EXCEPTION for specific web-sites/URLs/sites/servers so that ONLY THAT SPECIFIC SITE/SERVICE can work in TB. ( it means, the Web-Sites That You Will Add Inside Cookie-Exception List , Cookies From Only Those Web-Sites Will Be Accepted By TB ).

for twitter, you have to add these below URLs as Cookie-Exception sites: https://abs.twimg.com/ https://api.twitter.com/ https://pbs.twimg.com/ https://twitter.com/ https://mobile.twitter.com/ (copy one by one in above, and add into Cookie-Exception List) ( how to find out which exact URLs are needed in EXCEPTION ? use Firefox web-browser and NoScript addon in Firefox , set option in NoScript so that NO-website have permission to run/store any scripts/cookies . then goto this https://mobile.twitter.com/ site, and find out which permission you must give/allow, for the site to work properly, write them down in Notepad. )


send yourself an HTML based email with a below link, or send a message to your chat account in TB with below link: https://mobile.twitter.com/

in TB, right click on the above twitter link > open link in new tab > new browser-tab will appear inside the Thunderbird > you can login/sign-in to your twitter account, and use Twitter services.


even if twitter disables their mobile site/service , just https://twitter.com/ will also work fine, but it consumes more RAM memory & more other computing resource & more data resources, etc.


you can right-click on any link & also twitter link, and choose "Open Link in New Tab", to open it inside a browser-tab inside the TB. when you right-click on any link inside TB, TB will also show "Open Link in Browser" (default option), you can choose that too, to open the link in an external (default) web-browser.

more options

I have a similar problem since December last year,

So I posted it here and, more specific, here. The last solution; create a new profile, actually resetting Thunderbird did seem to do the trick (thanks again Sfhowes !) But after a couple of days... Well... I could not open my hyperlinks in messages again... and after rebuilding... and...

Finally neither rebuilding your database/profile, reinstalling Thunderbird completely, reinstalling Windows completely, updating Thunderbird from 68 to 78 or installing a complete new pc did solve this issue! Yes it works for a couple of days... Then starting over again not opening hyperlinks in your default web-browser. You can tell 'em that here and they do try to help you, but they won't believe you when you say; I think this is a bug, no, it is all your database/profile...

Luckily I found a simple solution in installing the 'Open With' add-on! Not having to bother by clicking with my right-mouse-button on any URL in a message, then selecting in which browser I would like to open it. With no problem!

Note; at the moment of writing Open With version 7.2.3 for Thunderbird version 78.x is seen as a old version, it can be found at the Thunderbird Open-With add-on versions page.

Good luck!

Modified by Charleshan

more options

OK I have had the same issue for only the past week. I have tried everything posted here but nothing has worked. What I do not understand is that the Twitter link is just a simple https link, and all other https links open correctly with Firefox, so what has actually changed to cause this? It is certainly nothing to do with the Twitter API or the app but seems specific to either Thunderbird or Firefox

more options

Great God! Life is to short for all this BS. I Dl'd and installed 'Open With" that seemed a simple solution. But no: it demanded more hoops and things I know nothing of. It should be bloody plug and play. A pox on Firefox for creating this stupid mess! Firefox should fix it as a common courtesy for their clientele and users.

more options

ArrowFlynn said

mel.richardson said

Thunderbird will not open a Twitter link emailed to my Thunderbird. It worked just fine till a few months ago. Gives a msg 'this file does not have an app associated with it. With a right click I can 'copy link location' and paste it into Firefox address line.

My mother encountered the same issue today. I had to remotely connect to her computer to fix the issue for her. Here's the fix:

1. In Thunderbird 78.4.3, navigate to Tools-->Options. Scroll all the way down to the "Config Editor" button. Click it.

2. Select "I Accept The Risk".

3. Search for "network.protocol-handler.warn-external.https" without the quotation marks.

The Twitter links that I'm sent are all https://

4. If network.protocol-handler.warn-external.https is set to false, right click on it, and select "Toggle", so that the value shows "true".

5. Exit Thunderbird. Run Thunderbird again.

6. Now click on the https://twitter link that you were emailed in Thunderbird.

7. A dialogue box will appear asking you to select the app. Presumably Firefox is already selected. The association doesn't work and needs to be fixed.

Select "Choose another application", and select the "Choose" button.

8. Locate firefox.exe on your computer. The location for me, since I'm running a 64 bit edition is C:\Program Files\Mozilla Firefox\firefox.exe

If you're running the 32 bit edition of Firefox, the file location might be found under C:\Program Files (x86)\Mozilla Firefox

Regardless, select the firefox executable file.

9. Check the box for "Remeber my choice for https links".

10. Click "Open Link"

11. Firefox should then launch your twitter link.

12. Go back into Thunderbird. Repeat steps 1 to 5, except this time change network.protocol-handler.warn-external.https to false in step 4.

13. That should fix the problem. If it doesn't, try going through the information listed at https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working starting with "Problems with received or saved mails" and work your way down.

Good luck!

Thanks ArrowFlynn! This works perfectly for me as of 29/3/2021. For a few years I was able to open Twitter links sent to me via Thunderbird email. Then suddenly I couldn't about a week ago about 23/3/2021. My Thunderbird version is 78.9.0.7751 and it says, "This file was released less than a week ago." ie about 23/3/2021. Looks like the new file is the guilty party. Thanks ArrowFlynn!