X
Tap here to go to the mobile version of the site.

Support Forum

Hyperlinks in messages do not work

Posted

When I click on a hyperlink in a message (http or https) I get no error message but the link does not launch in the browser. I went through the steps in https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working with no improvement: Thunderbird and Firefox set as default apps in Windows Started Thunderbird in safe mode Checked that no application is specified in "attachments" for http or https Verified no entry for "network.protocol-handler.external-..." in "Help->Troubleshooting Informaton" Deleted old profile and created a new one Re-installed Thunderbird 67.0.70 Installed Beta 67.0b3 (did not work so reinstalled 67.0.70 again).

System info: Thunderbird v 60.70.0 (32bit) running on Windows 10 (64 bit), build 17763.503, on a Lenovo X1 Extreme with Intel CPU. I have no other known software or hardware issues.

Any help would be much appreciated.

Thanks!

When I click on a hyperlink in a message (http or https) I get no error message but the link does not launch in the browser. I went through the steps in https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working with no improvement: Thunderbird and Firefox set as default apps in Windows Started Thunderbird in safe mode Checked that no application is specified in "attachments" for http or https Verified no entry for "network.protocol-handler.external-..." in "Help->Troubleshooting Informaton" Deleted old profile and created a new one Re-installed Thunderbird 67.0.70 Installed Beta 67.0b3 (did not work so reinstalled 67.0.70 again). System info: Thunderbird v 60.70.0 (32bit) running on Windows 10 (64 bit), build 17763.503, on a Lenovo X1 Extreme with Intel CPU. I have no other known software or hardware issues. Any help would be much appreciated. Thanks!

Chosen solution

the vast majority of these type of issues come from anti virus product or incorrectly set "default" browser.

You appear to be using Firefox. Try installing chrome and see if that jogs either windows or your anti virus to function correctly. If it does good. Either way as a result, install Firefox again because I am not telling you to USE chrome, just use the installer to clear up the registry entries..

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

Matt
  • Top 10 Contributor
  • Moderator
3290 solutions 22729 answers

Chosen Solution

the vast majority of these type of issues come from anti virus product or incorrectly set "default" browser.

You appear to be using Firefox. Try installing chrome and see if that jogs either windows or your anti virus to function correctly. If it does good. Either way as a result, install Firefox again because I am not telling you to USE chrome, just use the installer to clear up the registry entries..

the vast majority of these type of issues come from anti virus product or incorrectly set "default" browser. You appear to be using Firefox. Try installing chrome and see if that jogs either windows or your anti virus to function correctly. If it does good. Either way as a result, install Firefox again because I am not telling you to USE chrome, just use the installer to clear up the registry entries..

Modified by Matt

Was this helpful to you? 1
Quote

Question owner

Matt, I ran Chrome for a bit, which worked. Then reloaded Firefox, which now works too. NEVER would have figured this one out without help, thanks!

Matt, I ran Chrome for a bit, which worked. Then reloaded Firefox, which now works too. NEVER would have figured this one out without help, thanks!
Was this helpful to you?
Quote
Pangar 0 solutions 5 answers

Hi , I am using Thunderbird and when I create a hyperlink (ctrl K) it makes the text and hyperlink. However, upon sending it the person receiving it sees the text (non clickable) and the link (is clickable) beside it;

example as follows:

When I send it shows like: CLICK THIS LINK

When the emaiul is received it looks like:

click this link - the link itself (https://docs.google.com/spreadsheets)

Is there a setting to correct this? thanks L

Hi , I am using Thunderbird and when I create a hyperlink (ctrl K) it makes the text and hyperlink. However, upon sending it the person receiving it sees the text (non clickable) and the link (is clickable) beside it; example as follows: When I send it shows like: CLICK THIS LINK When the emaiul is received it looks like: click this link - the link itself (https://docs.google.com/spreadsheets) Is there a setting to correct this? thanks L
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3290 solutions 22729 answers

Received where? and in what format?

I just went through the motions using Thunderbird 68 (released soon) everything formats as it should as far as the HTML goes. However if your recipient is using some sort of web mail or an ancient text only mail program then the format you are suggesting would be what they see.

When I look at the message I created in Thunderbird using plain text what I see is;

Click this link <https://docs.google.com/spreadsheets>
Received where? and in what format? I just went through the motions using Thunderbird 68 (released soon) everything formats as it should as far as the HTML goes. However if your recipient is using some sort of web mail or an ancient text only mail program then the format you are suggesting would be what they see. When I look at the message I created in Thunderbird using plain text what I see is; Click this link <https://docs.google.com/spreadsheets>
Was this helpful to you?
Quote
Pangar 0 solutions 5 answers

Hi Matt an thanks for that.

I actually tried to send it to myself as well as others. Neither worked.

Your questions as to from where and in what format were a little confusing. I am using Thunderbird version 60.8.0 and composed a standard email. as I detailed in the earlier message, the title of the link seems to appear in text with the link following afterwards.

As you have managed to make this work it seems to me that there is some setting on my side that must be preventing this from working properly - any thoughts?

Thanks Luis

Hi Matt an thanks for that. I actually tried to send it to myself as well as others. Neither worked. Your questions as to from where and in what format were a little confusing. I am using Thunderbird version 60.8.0 and composed a standard email. as I detailed in the earlier message, the title of the link seems to appear in text with the link following afterwards. As you have managed to make this work it seems to me that there is some setting on my side that must be preventing this from working properly - any thoughts? Thanks Luis
Was this helpful to you?
Quote
Pangar 0 solutions 5 answers

Helpful Reply

UPDATE! I figured out what the issue is. For anyone else experiencing this it is simply the following:

Go to options/composition/send options/send message with html anyway

) now works!

thanks Matt for the help though L

UPDATE! I figured out what the issue is. For anyone else experiencing this it is simply the following: Go to options/composition/send options/send message with html anyway :) now works! thanks Matt for the help though L
Was this helpful to you? 1
Quote
Matt
  • Top 10 Contributor
  • Moderator
3290 solutions 22729 answers

That was where I was heading, but both is a better solution that HTML. I mentioned the ancient mail readers, if you send both they still get the message. IF you don't they get garbled HTML

If it was on Both, try setting a font in the composition option. Thunderbird will send in plain text if it thinks it can, but setting a font is usually enough to convince it it can not.

That was where I was heading, but both is a better solution that HTML. I mentioned the ancient mail readers, if you send both they still get the message. IF you don't they get garbled HTML If it was on Both, try setting a font in the composition option. Thunderbird will send in plain text if it thinks it can, but setting a font is usually enough to convince it it can not.
Was this helpful to you?
Quote
Charleshan 0 solutions 4 answers

mlewus said

When I click on a hyperlink in a message (http or https) I get no error message but the link does not launch in the browser.

I have almost the same problem on my Windows 10 Home edition machine since the recent update of Thunderbird to version 68.x, now version 68.2.2 (32-bits). If I do a right-mouse-button-click on a link in an e-mail I can select in the appearing menu 'Open in browser' which has the same result as clicking on the link itself; nothing happens, no error nothing... I can copy and paste the URL from Thunderbird to Firefox with no problem. Now comes the funny bit:

  1. If I click a http link in a e-mail the hyperlink works normal.
  2. If I click a https link in a e-mail, nothing happens!
  3. On my old PC still running on Windows 7 Starter edition with Thunderbird version 60.x, now version 60.9.1 (32-bits). Doesn't have any problem opening http or https hyperlinks.
  4. If I run Thunderbird portable version 60.9.1 (32-bits) on my Windows 10 machine (the one with the problem) it also has no problem opening http nor https hyperlinks!

Conclusion:

  • The local installed Thunderbird version 68.2.2 will open only http hyperlinks and no https hyperlinks.
  • If I use the portable Thunderbird version 60.9.1 on the same PC it has no problem opening http or https hyperlinks.
  • Since this is the case on the same machine I think I ruled out opening https hyperlinks being blocked by a app or add-on like a virus-scanner and we have detected a bug in Thunderbird version 68 opening https hyperlinks.

Any solutions or suggestions are welcome, thanks in advance! Charleshan


For your information; what I did thus far:

  • Thunderbird and Firefox set as default apps in Windows
  • Triggered by Matt's suggestion above (thanks!) I switched the default browser from Firefox to Internet Explorer and vice versa with no difference (ie: http urls open in default Internet Explorer but https won't and swiching back to default Firefox the same story)
  • Started Thunderbird in safe mode (no add-ons nor themes)
  • Checked that no application is specified in "attachments" for http or https
  • Verified no entry for "network.protocol-handler.external-..." in "Help->Troubleshooting Information"
  • I did not delete my old profile, nor did I remove and reinstall Thunderbird for I don't think this is the problem.

Notes:

''mlewus [[#question-1261756|said]]'' <blockquote> When I click on a hyperlink in a message (http or https) I get no error message but the link does not launch in the browser. </blockquote> I have almost the same problem on my Windows 10 Home edition machine since the recent update of Thunderbird to version 6'''8'''.x, now version 68.2.2 (32-bits). If I do a right-mouse-button-click on a link in an e-mail I can select in the appearing menu 'Open in browser' which has the same result as clicking on the link itself; nothing happens, no error nothing... I can copy and paste the URL from Thunderbird to Firefox with no problem. Now comes the funny bit: # If I click a http link in a e-mail the hyperlink works normal. # If I click a http'''s''' link in a e-mail, nothing happens! # On my old PC still running on Windows 7 Starter edition with Thunderbird version 6'''0'''.x, now version 60.9.1 (32-bits). Doesn't have any problem opening http or http'''s''' hyperlinks. # If I run Thunderbird '''portable''' version 6'''0'''.9.1 (32-bits) on my Windows 10 machine (''the one with the problem'') it also has '''no problem''' opening http nor http'''s''' hyperlinks! '''Conclusion:''' * The '''local installed''' Thunderbird version 6'''8'''.2.2 will open only http hyperlinks and '''no''' http'''s''' hyperlinks. * If I use the '''portable''' Thunderbird version 6'''0'''.9.1 on the '''same PC''' it has '''no problem''' opening http or http'''s''' hyperlinks. * Since this is the case on the ''same machine'' I think I ruled out opening http'''s''' hyperlinks being blocked by a app or add-on like a virus-scanner and we have detected a '''bug''' in Thunderbird version 6'''8''' opening http'''s''' hyperlinks. Any solutions or suggestions are welcome, thanks in advance! Charleshan '''For your information; what I did thus far:''' * Thunderbird and Firefox set as default apps in Windows * Triggered by ''Matt's [[#answer-1229902|suggestion above]]'' (thanks!) I switched the default browser from Firefox to Internet Explorer and vice versa with no difference (ie: http urls open in ''default'' Internet Explorer but https won't and swiching back to ''default'' Firefox the same story) * Started Thunderbird in safe mode (no add-ons nor themes) * Checked that no application is specified in "attachments" for http or https * Verified no entry for "network.protocol-handler.external-..." in "Help->Troubleshooting Information" * I did '''not''' delete my old profile, nor did I remove and reinstall Thunderbird for I don't think this is the problem. '''Notes:''' * All the software here mentioned is in the Dutch language and all of them are updated to the last versions, Thunderbird and Firefox by using the 'release-channel'. * Somehow the Thunderbird version on my old PC and the portable version are both up-to-date but not asking for an update to version 68.x? * I did al the checks from [[http://mzl.la/1BsOAb5|Hyperlinks in berichten werken niet]] which is the Dutch version of [[http://mzl.la/1BsOAb5|Hyperlinks in Messages Not Working]] * The Thunderbird portable edition I used can be found at: https://portableapps.com/apps/internet/thunderbird_portable
Was this helpful to you?
Quote
Charleshan 0 solutions 4 answers

Charleshan said

Should be:

''Charleshan [[#answer-1265565|said]]'' <blockquote> * I did al the checks from [[http://mzl.la/1BsOAb5|Hyperlinks in berichten werken niet]] which is the Dutch version of [[http://mzl.la/1BsOAb5|Hyperlinks in Messages Not Working]] </blockquote> Should be: * I did al the checks from '[http://mzl.la/1BsOAb5 Hyperlinks in berichten werken niet]' which is the Dutch version of '[http://mzl.la/1BsOAb5 Hyperlinks in Messages Not Working]'.
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3290 solutions 22729 answers

The hyperlinks in emails from this forum use HTTPS: I have had no issue at all opening them in firefox using Thunderbird 60.9, 68.0, 68.1 or 68.2.2

So I think that demonstrates that there is no bug in the English version, have you tried it just to see if it is only your localized version. Or you might reconsider the anti virus. They mostly play games using man in the middle hacking on HTTPS and it is a very common cause of issues. Primarily because they are hacking the connection. No anti virus scanning HTTPS no problem is the usual result.

The hyperlinks in emails from this forum use HTTPS: I have had no issue at all opening them in firefox using Thunderbird 60.9, 68.0, 68.1 or 68.2.2 So I think that demonstrates that there is no bug in the English version, have you tried it just to see if it is only your localized version. Or you might reconsider the anti virus. They mostly play games using man in the middle hacking on HTTPS and it is a very common cause of issues. Primarily because they are hacking the connection. No anti virus scanning HTTPS no problem is the usual result.
Was this helpful to you?
Quote
Charleshan 0 solutions 4 answers

Matt said

So I think that demonstrates that there is no bug in the English version, have you tried it just to see if it is only your localized version.

Hai Matt, thanks for the suggestions. Like I stated before:

Conclusion:
  • The local installed Thunderbird version 68.2.2 will open only http hyperlinks and no https hyperlinks.
  • If I use the portable Thunderbird version 60.9.1 on the same PC it has no problem opening http or https hyperlinks.
  • Since this is the case on the same machine I think I ruled out opening https hyperlinks being blocked by a app or add-on like a virus-scanner and we have detected a bug in Thunderbird version 68 opening https hyperlinks.
... and ...
Notes:
  • All the software here mentioned is in the Dutch language and all of them are updated to the last versions, Thunderbird and Firefox by using the 'release-channel'.
  • Somehow the Thunderbird version on my old PC and the portable version are both up-to-date but not asking for an update to version 68.x?
  • I did al the checks from 'Hyperlinks in berichten werken niet' which is the Dutch version of 'Hyperlinks in Messages Not Working'.
  • The Thunderbird portable edition I used can be found at: portableapps.com

So I understand the bug appears only in the Dutch and not the English version?

  • As I stated; I tried both the local installed as the portable Thunderbird on the same machine of which the Dutch localized version 68.2.2 will open only http and no https hyperlinks (with same result in save mode so without virusscanner) and the Dutch portable version 60.9.1 will open any hyperlink (no need to run it in save mode).
  • I tested this by sending myself an e-mail containing only http://mzl.la/1BsOAb5 https://support.mozilla.org/nl/questions/1261756 which I tried to open in both Thunderbird versions on the same machine with the same viruscanner.
''Matt [[#answer-1267231|said]]'' <blockquote> So I think that demonstrates that there is no bug in the English version, have you tried it just to see if it is only your localized version. </blockquote> Hai Matt, thanks for the suggestions. [[#answer-1265565|Like I stated before]]: <blockquote> '''Conclusion:''' * The '''local installed''' Thunderbird version 6'''8'''.2.2 will open only http hyperlinks and '''no''' http'''s''' hyperlinks. * If I use the '''portable''' Thunderbird version 6'''0'''.9.1 on the '''same PC''' it has '''no problem''' opening http or http'''s''' hyperlinks. * Since this is the case on the ''same machine'' I think I ruled out opening http'''s''' hyperlinks being blocked by a app or add-on like a virus-scanner and we have detected a '''bug''' in Thunderbird version 6'''8''' opening http'''s''' hyperlinks.</blockquote> ''... and ...'' <blockquote>'''Notes:''' * All the software here mentioned is in the '''Dutch''' language and all of them are updated to the last versions, Thunderbird and Firefox by using the 'release-channel'. * Somehow the Thunderbird version on my old PC and the portable version are both up-to-date but not asking for an update to version 68.x? * I did al the checks from '[https://support.mozilla.org/nl/kb/hyperlinks-in-berichten-werken-niet Hyperlinks in berichten werken niet]' which is the Dutch version of '[https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working Hyperlinks in Messages Not Working]'. * The Thunderbird portable edition I used can be found at: [https://portableapps.com/apps/internet/thunderbird_portable portableapps.com] </blockquote> So I understand the bug appears only in the '''Dutch''' and not the '''English''' version? * As I stated; I tried both the '''local installed''' as the '''portable''' Thunderbird on the ''same machine'' of which the '''Dutch localized ''' version 6'''8'''.2.2 will open only http and '''no''' http'''s''' hyperlinks (with same result in [http://mzl.la/1HjODai save mode] so ''without virusscanner'') and the '''Dutch portable''' version 6'''0'''.9.1 will open '''any''' hyperlink (no need to run it in [http://mzl.la/1HjODai save mode]). * I tested this by sending myself an e-mail containing '''only''' [http://mzl.la/1BsOAb5 http://mzl.la/1BsOAb5] [https://support.mozilla.org/nl/questions/1261756 http'''s'''://support.mozilla.org/nl/questions/1261756] which I tried to open in '''''both''' Thunderbird versions on the '''same machine''' with the '''same''' viruscanner''.

Modified by Charleshan

Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3290 solutions 22729 answers

No you have not installed the English version on your machine, where you have the issue to determine if it is a localization issue.

This is what I suggest you do. To diagnose problems with Thunderbird, try one of the following:

  • Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender.
  • Restart the operating system in safe mode with Networking. This loads only the very basics needed to start your computer while enabling an Internet connection. Click on your operating system for instructions on how to start in safe mode: Windows 10, Windows 8, Windows 7, Windows Vista, Windows XP, OSX

When it works in safe mode, we will be back to an app on your computer. Disable your anti virus interference

Just be aware Anti virus programs use the version of programs to deny them access to the internet. Your test with 60 Vs 68 only reinforce the probability you have a problem with your security suite.

No you have not installed the English version on your machine, where you have the issue to determine if it is a localization issue. This is what I suggest you do. To diagnose problems with Thunderbird, try one of the following: *Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender. *Restart the operating system in '''[http://en.wikipedia.org/wiki/Safe_mode safe mode with Networking]'''. This loads only the very basics needed to start your computer while enabling an Internet connection. Click on your operating system for instructions on how to start in safe mode: [https://support.microsoft.com/en-us/help/12376/windows-10-start-your-pc-in-safe-mode Windows 10], [http://windows.microsoft.com/en-us/windows-8/windows-startup-settings-safe-mode Windows 8], [http://windows.microsoft.com/en-us/windows/start-computer-safe-mode#start-computer-safe-mode=windows-7 Windows 7], [http://windows.microsoft.com/en-us/windows/start-computer-safe-mode#start-computer-safe-mode=windows-vista Windows Vista], [http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx?mfr=true" Windows XP], [http://support.apple.com/kb/ht1564 OSX] When it works in safe mode, we will be back to an app on your computer. Disable your anti virus interference Just be aware Anti virus programs use the version of programs to deny them access to the internet. Your test with 60 Vs 68 only reinforce the probability you have a problem with your security suite.
Was this helpful to you? 0
Quote
Charleshan 0 solutions 4 answers

Matt said

This is what I suggest you do.

Thanks Matt, I Did like you suggested,

  • As you might have noticed I did already restarted Thunderbird in Safe Mode so I did this again and with the same (no) results; i.e. it will open only http and no https hyperlinks.
  • I also restarted my Dutch Windows 10 operating system in save mode with the following results:
  1. Local installed Thunderbird version 68.2.2 (32-bits) in normal mode, the OS in save mode: The same (no) results; it opens only http and no https hyperlinks.
  2. Local installed Thunderbird version 68.2.2 (32-bits) in save mode, the OS in save mode': The same (no) results; it opens only http and no https hyperlinks.
  3. Portable Thunderbird version 60.9.1 (32-bits) in normal mode on the same PC, the OS still running in save mode: It has again no problem opening http or https hyperlinks.
  4. Since it already worked in normal mode I did not try Portable Thunderbird in save mode.

Since there is no difference running my PC in save mode or not and running thunderbird in save mode (on my PC's OS in save mode) or not. I still believe there is a bug in the Dutch version of Thunderbird version 68.x.

HTTP versus HTTPS issue in Thunderbird version 68.x is still not solved, any new suggestions are welcome, thanks in advance! Charleshan

PS. I don't know if I mentioned it here but I also tested the local installed Thunderbird version 68.2.2 (32-bits) with my PC in normal mode and my PC's virusscanner disabled.

''Matt [[#answer-1267315|said]]'' <blockquote> This is what I suggest you do. </blockquote> Thanks Matt, I Did like you suggested, * As you might have noticed I did already ''restarted Thunderbird in Safe Mode'' so I did this again and with the same (no) results; i.e. it will open ''only'' http and ''no'' http'''s''' hyperlinks. * I also restarted my Dutch Windows 10 operating system in [https://support.microsoft.com/nl-nl/help/12376/windows-10-start-your-pc-in-safe-mode save mode] with the following results: # '''Local installed''' Thunderbird version 6'''8'''.2.2 (32-bits) in '''normal''' mode, the OS in ''save'' mode: The same (no) results; it opens ''only'' http and ''no'' http'''s''' hyperlinks. # '''Local installed''' Thunderbird version 6'''8'''.2.2 (32-bits) in '''save''' mode, the OS in ''save'' mode': The same (no) results; it opens ''only'' http and ''no'' http'''s''' hyperlinks. # '''Portable''' Thunderbird version 6'''0'''.9.1 (32-bits) in '''normal''' mode on the same PC, the OS still running in ''save'' mode: It has again ''no problem'' opening http or http'''s''' hyperlinks. # Since it already worked in '''normal''' mode I did not try '''Portable''' Thunderbird in '''save''' mode. Since there is ''no difference'' running my PC in save mode or not ''and'' running thunderbird in save mode (on my PC's OS in save mode) or not. I still believe there is a bug in the ''Dutch'' version of Thunderbird version 6'''8'''.x. HTTP versus HTTP'''S''' issue in Thunderbird version 6'''8'''.x is still not solved, any new suggestions are welcome, thanks in advance! Charleshan PS. I don't know if I mentioned it here but I also tested the local installed Thunderbird version 68.2.2 (32-bits) with my PC in ''normal'' mode and my PC's virusscanner ''disabled''.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.