Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some websites don't work correctly in Firefox but do work using Edge.

  • 9 replies
  • 1 has this problem
  • 20 views
  • Last reply by mnmshadow

more options

Problem: viewing radar at weatherunderground.com using Firefox only works in Safe Mode. This problem started about 3 weeks ago. The radar also works correctly using Edge. Advice? It has to be a Firefox setting that I have wrong. I have already tried "refreshing Firefox". That caused me a lot of grief trying to get bookmarks back.

All Replies (9)

more options

mnmshadow said

Problem: viewing radar at weatherunderground.com using Firefox only works in Safe Mode

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

more options

mnmshadow said

I have already tried "refreshing Firefox". That caused me a lot of grief

Look on your desktop. Do you see a folder called; Old Firefox? Look inside. Look for the folder with the latest creation date.

https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible

Helpful?

more options

Hello Fred, and THANK YOU for jumping on this so quickly!

1) I disabled Hardware Acceleration – no change. The radar only works in Safe Mode.

2) I didn’t have any extensions, just the default theme, and 3 plugins. 2 of them are defaults; the 3rd, Adobe, I added today (before I sent the note) since I read on one of Firefox’s pages that I needed Adobe Flash. I disabled each one (one at a time) and restarted FF. No difference. Only works in Safe Mode.

I’m attaching screen prints of the Add-ons Manager so you can see what I’ve done.

Just an FYI – I’m not a guru in all of this – but I’m learning quickly, I think !

3) Your second email – I did find the folder (didn’t know it was there). I’ve been busy trying to get this other stuff for you, so I haven’t followed those links yet.

Just so you’ll know that I’m not deserting this, I’ll be signing off after I send this. I have to be in Knoxville early tomorrow morning, but should be home after 6:00 pm (on 10/26 – tomorrow).

Thank you extremely for your help. I’ll look forward to your continued feedback.


Paul

Helpful?

more options

This will help you!

Go and clear the Recent History including Offline Website Data

Modified by Vikas Singh

Helpful?

more options

Thanks, Vikas, for the suggestion. It screwed up a lot of stuff but did not fix the problem. The radar (rain/snow) only shows up in Safe Mode. I cleared everything for all time.

Paul

Helpful?

more options

Remove History For One Site {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings

Helpful?

more options

Hello Fred, It's amazing how life can get extremely busy when you commit to working on a problem. Sorry for the delay getting back. I have not tried "Forget about this Site" yet, as I had tried what Vikas suggested - it appears to have cleared everything for everything. I have also been playing detective on my own. We have a standard phrase around our house, "When logic fails, try blonde-logic!!" If I'm stuck on a problem, my wife will come in, see what's going on, and suggest something that I would never think of. More times than not, it works. She came in, looked over what all I've been doing, and asked me if I had tried turning off Kaspersky Internet Security. I replied, "no". She reminded me of a similar problem a few years ago, so I tried it! I just tried it before signing on here. It worked! The radar works with Kaspersky turned off. I turned it off, then closed FF, opened FF, then weatherunderground.com, clicked their 'wundermap', and the radar shows. I then turned Kaspersky Internet Security back on again and just refreshed the map - no more radar. I haven't tried this on the other sites that aren't working yet - I wanted to be sure to update this asap. The ugly part is that it looks like I'll have to deal with Kaspersky Support - not always an easy thing.

Helpful?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Load the webpage. Then click the Kaspersky icon > setting and disable it on that site.

Helpful?

more options

Thanks.......desperation pushes us at times! Before I flag the post as solved, I tried the other site that I knew for sure doesn't work ..... chase.com. Turning off Kaspersky did not solve the problem there. Should I close this session as solved and then start up one for chase.com?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.