Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New Tab Pocket Settings Missing

  • 9 replies
  • 1 has this problem
  • 25 views
  • Last reply by K00lman

more options

I had accidentally refreshed my Firefox, and after adding back all my old data, I found that the pocket stories were missing form my new tab. I manged to fix this issue, but when I go into new tab settings to make it show more than 3 stories, there are no options for them. It just gives me options for search, top sites, highlights, and snippets. How do I get these settings back?

Chosen solution

I just open the browser again, and its began opening as before, then just fixed itself as well as changing some of the top sites. I don't know what I did to fix this.

Read this answer in context 👍 0

All Replies (9)

more options

I'm not sure how to control the number of Pocket recommendations at the moment. There is a preference in about:config for the number of rows, but even with that set to 1, I am getting 7 rows. ??? If you want to give that a try anyway:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste topstories and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.section.topstories.rows preference to display an editing field, and change the value to, for example, 3 and then press Enter or click the blue check mark button to save the change.

More info on about:config: Configuration Editor for Firefox.

Helpful?

more options

jscher2000 said

I'm not sure how to control the number of Pocket recommendations at the moment. There is a preference in about:config for the number of rows, but even with that set to 1, I am getting 7 rows. ??? If you want to give that a try anyway: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste topstories and pause while the list is filtered (3) Double-click the browser.newtabpage.activity-stream.section.topstories.rows preference to display an editing field, and change the value to, for example, 3 and then press Enter or click the blue check mark button to save the change. More info on about:config: Configuration Editor for Firefox.

Changing that number did not do anything. I have included a little picture of what is missing from my other computer, but even on this other computer, it does not have the little drop down to change number of rows. Is there anyway to get this back?

Helpful?

more options

I don't know how you are getting only one row in a clean (post-Refresh) profile. I thought everyone has been getting 7 rows since Firefox 69, and there has been no selector on the Options/Preference page for that since Firefox 69.

??

Helpful?

more options

See also:

  • Bug 1580542 - Allow Users To Control How Many Pocket Stories Are Displayed in New Tab

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Helpful?

more options

jscher2000 said

I don't know how you are getting only one row in a clean (post-Refresh) profile. I thought everyone has been getting 7 rows since Firefox 69, and there has been no selector on the Options/Preference page for that since Firefox 69. ??

Its not quite post refresh, as I restored all my old stuff, if that makes anything more clear.

Helpful?

more options

Did the old stuff include a userContent.css file (optional file you can use to modify the appearane of the new tab page or other internal pages)?

Helpful?

more options

jscher2000 said

Did the old stuff include a userContent.css file (optional file you can use to modify the appearane of the new tab page or other internal pages)?

Not that I could find.

Helpful?

more options

userChrome.css and userContent.css would be located in the chrome folder in the profile folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You can try to rename prefs.js to prefsOLD.js to reset all prefs to see if that has effect.

Helpful?

more options

Chosen Solution

I just open the browser again, and its began opening as before, then just fixed itself as well as changing some of the top sites. I don't know what I did to fix this.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.