Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Automatically mark messages as read" works only in safe mode

  • 13 replies
  • 1 has this problem
  • 34 views
  • Last reply by Toad-Hall

more options

"Automatically mark messages as read" has suddenly stopped working after the update to TB 68.11.0 (64-bit). When i start TB in safe mode, it works fine. In normal mode, even if i manually disable all addons and restart, it just does not work anymore.

When i click on a bold message, it stays bold. I have to click on the green dot in the "read" column for it to be marked as "read".

I tried disabling and re-enabling all relevant settings in the "Options\Display" panel, without any luck.

Chosen solution

Well, i tried disabling all relevant options (spam, antivirus, junk) and antivirus itself, but nothing changed. As i was trying various stuff though, i noticed that TB was automatically upgraded from 68.11 to 68.12.1 and all of the sudden, the problem disappeared!

I re-enabled everything and it now works as expected! I'm guessing it was a bug /side-effect of something, which was somehow fixed. As i see now, TB is also offering to be upgraded to 78.4, so i'll go ahead and do that too.

Thanks to everyone for your help and ideas.

Read this answer in context 👍 0

All Replies (13)

more options

If it works in safe mode, it means there is either an incompatible add-on or theme, or a broken layout. There are other possibilities, but those are the most common. Check your add-ons, or repair the layout by launching in safe mode and checking 'Reset toolbars and controls', then 'Make changes and restart'.

Helpful?

more options

I performed the 'Reset toolbars and controls', then 'Make changes and restart' method but nothing changed.

What puzzles me is that in safe mode (which disabled addons) does work, but when i disable addons manually, it doesn't! This means to me that the cause is not an addon. It's something else, but i can't understand what. A setting maybe? What else does "safe mode" do, except disabling addons?

Helpful?

more options

The next thing to check is the hardware acceleration setting:

https://support.mozilla.org/en-US/questions/1309612#answer-1360188

The mozillazine article cited above explains the effects of safe mode.

Helpful?

more options

Well, i found it, disabled it and restart. No change in TB's behavior. Anything else i can check?

Helpful?

more options

Are you using a non-default theme in normal mode, or any custom css files?

Helpful?

more options

Nope. I've used custom css in Firefox only, not Thunderbird. Also, the theme is the default.

Are there perhaps any related "advanced" settings i could check?

Helpful?

more options

At this point, it's probably faster and more effective to create a new profile, add an account, and see if it works properly. Help/Troubleshooting, about:profiles, to create and manage profiles. Your current profile is unaffected and can be run from about:profiles. If the new profile works, data from the old one can be transferred to the new.

Consider also updating to 78.4 (check Tools/Options/Advanced/Update), as 68 is essentially end-of-life.

Helpful?

more options

I will try that, thanks.

You said: Consider also updating to 78.4 (check Tools/Options/Advanced/Update), as 68 is essentially end-of-life.

!!!!!!! Why didn't it automatically update to the newer version? I have "auto-updates" turned on and pressing "check for updates" reports "TB is up to date"!

Helpful?

more options

Auto updates have just resumed with the release of 78.4. Because of previous problems with the 68 to 78 process, auto update was suspended, but is now being deployed gradually. You can install 78 manually, or wait until auto update reaches your setup. If you install 78 manually, I recommend starting a new profile with 78 anyway.

Helpful?

more options

I see. Thanks for the info and your advice. I'll update to 78 and hopefully the problem will be fixed.

Helpful?

more options

Is it possible this is an interaction with a spam filter or something from an anti virus. Thunderbird safe mode disabled the addon interfaces to create the mode as I understand it. So external software that is using them, but not registering their addon as installed would leave mystery changes that are difficult to explain.

Helpful?

more options

Chosen Solution

Well, i tried disabling all relevant options (spam, antivirus, junk) and antivirus itself, but nothing changed. As i was trying various stuff though, i noticed that TB was automatically upgraded from 68.11 to 68.12.1 and all of the sudden, the problem disappeared!

I re-enabled everything and it now works as expected! I'm guessing it was a bug /side-effect of something, which was somehow fixed. As i see now, TB is also offering to be upgraded to 78.4, so i'll go ahead and do that too.

Thanks to everyone for your help and ideas.

Helpful?

more options

Please note that some chnages occur when you update to 78, so before updating I would advise you exit Thunderbird and make a backup copy of your current profile name folder - just in case you want to go back and put it in a folder that has the name of the last version used on that profile eg: TBv68.12.1 Then go ahead and update.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.