Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bank signon stopped working after last updates

  • 4 replies
  • 1 has this problem
  • 11 views
  • Last reply by FredMcD

more options

As of Friday October 16, 2020 my bank sign on stopped working. I called the bank and they asked me to use my Microsoft edge browser and it worked.

Any Idea on why this on site does not work? I cleared cache and cookies and rebooted.

Attached screenshots

All Replies (4)

more options

Please explain the problem in detail. What happens? What is/are the exact error message(s) ?

Helpful?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (DuckDuckGo PE, Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.

Helpful?

more options
In a private message,

dale.traylor said]]

here is what is happening. I go to the secure site for logging into my bank and I add my password and userid and press enter. It gives me a message "We found some errors, please review the form and make corrections...This only happens from my home computer with windows 10. All my other devices work fine with firefox. Also, microsoft edge works fine at the site. Bank has no idea. I have deleted firefox and reinstalled to no avail..Twice....I can send a screenshot if necessary!

Helpful?

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.