Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Delete all cookies when Firefox closes except some specific ones

  • 4 replies
  • 1 has this problem
  • 40 views
  • Last reply by cor-el

more options

Using Firefox 68.12.0ESR. I know 78 is available, I just haven't had the time to test it yet. I delete cookies when I exit Firefox. I want to keep some for sites that I trust, such as this site. I've added exceptions to Allow these trusted sites as documented on a thread somewhere else, but it doesn't work. All cookies are deleted.

Is it possible to keep cookies only for a select group of sites. eg. support.mozilla.com, tomshardware.com, mydigitallife.net, speedtest.net and so on.

Thank you.

Chosen solution

You can let the cookies expire when Firefox is closed to make them session cookies instead of using "Clear history when Firefox closes" to clear all cookies including cookies with an allow exception you may want to keep.

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: [ ] "Delete cookies and site data when Firefox is closed"

You can create a cookie allow exception with the proper protocol (https:// or http://) for websites you want to remember you.

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Exception"

Note that you only keep cookies with an allow exception if you use "Delete cookies and site data when Firefox is closed". Deleting cookies otherwise removes all selected cookies.

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

You can let the cookies expire when Firefox is closed to make them session cookies instead of using "Clear history when Firefox closes" to clear all cookies including cookies with an allow exception you may want to keep.

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: [ ] "Delete cookies and site data when Firefox is closed"

You can create a cookie allow exception with the proper protocol (https:// or http://) for websites you want to remember you.

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Exception"

Note that you only keep cookies with an allow exception if you use "Delete cookies and site data when Firefox is closed". Deleting cookies otherwise removes all selected cookies.

Helpful?

more options

Ah... I see what I did. I have both the clear history options ticked. Removed the tick from the one under History and it's working now. Thanks for your help.

Helpful?

more options

This fix does not work for me in Firefox 83.0 It stopped working a week ago and i can't fix it. Why?

Helpful?

more options

Firefox 82+ comes with a "Redirect Tracking Protection" feature to purge tracking cookies for websites automatically.

You can disable the feature to purge tracking cookies automatically via the about:config page.

  • privacy.purge_trackers.enabled = false

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.