Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't unpin a site

more options

Hi, I opened Firefox this morning and found Amazon pinned among my top sites. Weirdly enough, I can't unpin it or dismiss it - it just stays there whatever I do (in contrast to other pinned sites). It's not a huge problem, but I have some ethical issues with Amazon, so the last thing I want to see every time I open my browser is their logo. I also wonder how did it get there in the first place (I sometimes do browse the site to get an idea what are the prices of various products, but not too often and I'm not sure if there is a way to pin it by accident at all). Does anyone have the same problem?

Chosen solution

Hi, I'm not sure if it was a search engine site (it didn't have the blue search icon on it at least), nonetheless adding Amazon as a search engine site (and then removing it) somehow solved the issue as it replaced the pinned site!

Read this answer in context 👍 0

All Replies (7)

more options

Hi, that sounds like a search engine site. Please see:

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Helpful?

more options

Chosen Solution

Hi, I'm not sure if it was a search engine site (it didn't have the blue search icon on it at least), nonetheless adding Amazon as a search engine site (and then removing it) somehow solved the issue as it replaced the pinned site!

Helpful?

more options

Hey! I had the exact same issue. Your solution didn't work for me, but here's what did. Click the three dots on the upper right hand corner of the icon > Edit > Change the url and name to something other than Amazon (I used an article about Amazon's disgusting attempts to quash unions for irony) > Save. Reload the page then click the three dots > Unpin. It should be gone! Cheers

Modified by sam.eliot.bernstein

Helpful?

more options

The above solutions don't work for me. I have two rows of frequent sites and all that happened is it moved Amazon from the first site listed to one on the second row. I still can't delete it from history or unpin it

Modified by lbiggs62

Helpful?

more options

For all still having the problem. For me worked:

1) open "about:config" 2) search "amazon" 2.a) edit "browser.newtabpage.searchTileOverride.amazon.attributionURL" and delete content of string 2.b) edit "browser.newtabpage.searchTileOverride.amazon.url" and delete content of string 2.c) edit "app.normandy.startupExperimentPrefs.browser.newtabpage.searchTileOverride.amazon.attributionURL" and delete content of string 2.d) edit "app.normandy.startupExperimentPrefs.browser.newtabpage.searchTileOverride.amazon.url" and delete content of string 3) search "pinned" 3.a) edit "browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts.havePinned" and delete content of string 3.b) edit "browser.newtabpage.pinned" and delete content of string

3) attention: could unpin other of your pinned sites, if you have any.

Video to what happens if you delete them step by step: https://www.youtube.com/watch?v=i4r9lyyODos

Thanks - Michael

Helpful?

more options

lbiggs62 said

The above solutions don't work for me. I have two rows of frequent sites and all that happened is it moved Amazon from the first site listed to one on the second row. I still can't delete it from history or unpin it

I hope you will find my post and solve the problem with my informations.

Helpful?

more options

Maybe you need to delete the amazon-site from topsites afterwards because it seems that it pops up again on first place if you don't delete it.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.