Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Site keeps detecting ad blocker after all blocker extensions removed and Enhanced Protection turned off

  • 6 replies
  • 4 have this problem
  • Last reply by marbolot

more options

I am using Firefox 81.0.

Specifically, I am trying to "Enable earning" on the Southwest Airlines Rapid Rewards shopping site -- I have uninstalled all ad blockers and trackers (AdBlocker Plus, Ghostery, Duck Duck Go, etc.) and turned off Firefox Enhanced Tracking Protection for the site. And still I get this warning at the top of the page:

"AdBlock, uBlock, AdBlockPlus or another ad blocker or Firefox Tracking Protection may be preventing you from earning points on your shopping. "

Does anyone know what is going on?

I am running Kaspersky Total Security. Could that be the culprit? What troubleshooting can I do to find the root cause of the Southwest site detecting an "ad blocker of Firefox Tracking Protection"?

All Replies (6)

more options

Are you possibly using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History) as this also can cause such an issue ?

more options

Thanks for the suggestion, @cor-el. I checked whether Private Browsing was on, and it was not. Since I opened this thread, I tried it on a different machine on which I have no problems, even though I have AdBlock Plus, Ghostery, and DuckDuckGo Essentials installed (but all disabled for the Southwest shopping site). The primary difference between the two machines is that the first one (where I keep getting the ad blocker warning, despite having removed ALL blockers and privacy protection) is Windows 8.1, while the second machine (which handles the SW shopping site fine) is Windows 10. So, I guess it's actually a Windows problem???

more options

It is possible that (anti-virus) security software is causing the problem. Try to disable security software temporarily to see if that makes a difference.

This might be caused by some setting changes you made in Firefox that you forgot about.

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Thanks again. I tried disabling Kaspersky security software, and it didn't solve the problem.

I also created a new profile, opened Firefox using it and confirmed that no ad blockers were running (in fact, I removed ALL add-ons) and turned off Firefox Tracking Protection for the site, and I still get the warning message to turn off ad blocking.

Must be a Windows 8 thing.

more options

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

That worked. In Win 8 Safe Mode with networking, I no longer get the ad blocker warning on

So what does that say about Windows 8?