Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird 78.2.2 crashes @ nsMsgFilterAfterTheFact::ApplyFilter after update

  • 7 replies
  • 1 has this problem
  • 51 views
  • Last reply by Wayne Mery

more options

Thunderbird just updated to v78.2.2 and crashes after restart while downloading email. I've tried safe mode and get the same results. I tried uninstalling and reinstalling and also tried uninstalling and installing the previous b78.2.1 version, all with same crash result.

Crash ID: bp-23b5e8e0-be95-4485-a999-0f2da0200919

I am stuck. What can I do?

Thanks!

Modified by Wayne Mery

Chosen solution

nsMsgFilterAfterTheFact::ApplyFilter - I think it's a solved bug that reappeared as some logs report it again since v 78.0.1

I would downgrade to v68 even if it's not recommended... You should mention though as many details (server type, antivirus, how many accounts) For downgrade (and using old settings, so same profile) follow these steps:


You should download the right version for your computer/operating system from here https://archive.mozilla.org/pub/thunderbird/releases/68.9.0/

On last step of the installation do NOT select to start tb. If you miss this step an error will appear - on that screen click exit!

After installed go to run (search run, select that run app) and write on that small field this: thunderbird --allow-downgrade Press enter and that's all. You will have 68 working.

After that go to Option - Update - change update to manually and disable update service. After that you can search for updates manually (should suggest 68.12 - this one you can update). Please note that you will need to search on add-ons page the versions which are working with 68.0* - those with 78* will not work

Read this answer in context 👍 1

All Replies (7)

more options

Chosen Solution

nsMsgFilterAfterTheFact::ApplyFilter - I think it's a solved bug that reappeared as some logs report it again since v 78.0.1

I would downgrade to v68 even if it's not recommended... You should mention though as many details (server type, antivirus, how many accounts) For downgrade (and using old settings, so same profile) follow these steps:


You should download the right version for your computer/operating system from here https://archive.mozilla.org/pub/thunderbird/releases/68.9.0/

On last step of the installation do NOT select to start tb. If you miss this step an error will appear - on that screen click exit!

After installed go to run (search run, select that run app) and write on that small field this: thunderbird --allow-downgrade Press enter and that's all. You will have 68 working.

After that go to Option - Update - change update to manually and disable update service. After that you can search for updates manually (should suggest 68.12 - this one you can update). Please note that you will need to search on add-ons page the versions which are working with 68.0* - those with 78* will not work

Helpful?

more options

Thank you FfTh202009!

For the successful suggestion including all the details. Will the nsMsgFilterAfterTheFact::ApplyFilter (re)bug get posted in the appropriate place so it will be attended to? I would eventually like to update to the latest.

Thanks again, Chuck

Modified by Wayne Mery

Helpful?

more options

Try to mention as many details of the account types that you had/have and antivirus software and when did you think it happened. Your feedback might be important so the bug to be solved.

Helpful?

more options

I experienced the crash on first Thunderbird restart after update to 78.2.2 Antivirus software: Avast Premium Security account types: 2 POP and 2 IMAP 18 different Message filters

Helpful?

more options

Tks for the feedback! A question though: On the filters - are there some related with those IMAP accounts and maybe action to copy or move to trash/spam or some nonexistent folder or folders with special characters?

Helpful?

more options

As far as I can tell, the filters are all working on the inbox of a POP account. I went through them and did not see any actions going to non-existent folders. No special characters besides dash "-" or space.

Helpful?

more options

I have filed a bug report for this https://bugzilla.mozilla.org/show_bug.cgi?id=1666115

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.