Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not showing my 404 page if a page does not exist

  • 5 replies
  • 1 has this problem
  • 49 views
  • Last reply by jscher2000

more options

Firefox does not display my 404 page if a page or download no longer exists, instead it shows an advertisement page, under my domain name, for sedo.com

This is not happening in Chrome, which does display my 404 page.

What could be wrong?

Chosen solution

professorcad said

In safe mode, still the same. If you try main part of url followed by /PB_Stuff?

Yes, that gives me the problem. It returns a 403 (Forbidden) code along with the page. Maybe you can set up a handler for 403 errors and redirect them back to the home page?

Read this answer in context 👍 0

All Replies (6)

more options

That's strange. Often an ISP will display a parking/auction page is there is no site, but not just for one page missing on an active site. Is Firefox getting redirected to a different server? Check for an embedded/framed page by right-clicking the background of the unexpected page and looking for "This Frame". If you have that submenu, you can choose View Frame Info to see its URL.

Does your site use HTTPS?

Helpful?

more options

Thanks for responding. This is the info: https://sedoparking.com/search/registrar.php?domain=www.professorcad.co.uk&rpv=2®istrar=IONOSParkingUK&gst=3B1ggkaXdfTpoEF50fXXviqF8N0tlIADrF5p0GhPQugyUvH3TLVFbf7I5Ch7L29HHmXvq40Cxaim-IgvvvcvcPmz9knpxWFCxW0&ref=

IONOS is my website host. What I have discovered:

1) If I simply enter a nonsense URL, my 404 page is displayed. 2) If I enter a URL that includes an existing directory on the server followed by a nonsense page, the sedo page is displayed.

My site is HTTPS and has been so for years (back to when IONOS were 1 & 1)

Helpful?

more options

Since we are discussing URLs, replies may be delayed in appearing due to the forum's link moderation (anti-spam) feature.

I assuming you have some kind of "clean URLs" code running either in a server-side script file or in a .htaccess or equivalent file, but normally that would work the same for all browsers.

I'm not sure anyone but you knows your directory structure -- none of these gave me a parking page:


To rule out extensions as a possible culprit, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

more options

In safe mode, still the same. If you try main part of url followed by /PB_Stuff?

Helpful?

more options

.... I think it's possibly an error by the Host. I have emailed them.

Helpful?

more options

Chosen Solution

professorcad said

In safe mode, still the same. If you try main part of url followed by /PB_Stuff?

Yes, that gives me the problem. It returns a 403 (Forbidden) code along with the page. Maybe you can set up a handler for 403 errors and redirect them back to the home page?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.