Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't go in any google page

  • 4 replies
  • 1 has this problem
  • 11 views
  • Last reply by cor-el

more options

Hello: I am traying to go in google.com and I get:

Secure connection failed An error has occurred while connecting to www.google.com.

   The page you are trying to view cannot be displayed because the authenticity of the received data could not be verified.
   Contact the website owners to report this problem.

It's working fine with other browsers. I just updated today to 79.0 (64 bit). In the same network other people is working fine with same version.

Any help? Rober

All Replies (4)

more options

https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean

Often, "Secure Connection Failed" means "Connection Failed (trying to load a secure page)". In other words, not a security problem, just a connection problem.


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

more options

Thanks for the reply but none of the above has worked. It seems that the connection despite being https does not connect that way. Attached photo, in Spanish. Translated "Información del sitio para www.google.com"="Site information for www.google.com". "Conexión no segura"="Unsecured connection" "Permiso"="Permissions" "No se ha concedido nungún permiso especial a este sitio"="No special permission has been granted to this site". The rest of the companions work well in Firefox and the other browsers work well too. Thanks Róber

Helpful?

more options

Helpful?

more options

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.


You can do a malware scan just to be sure.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.