Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

layout.css.scrollbar-width.enabled not working

  • 2 replies
  • 1 has this problem
  • 148 views
  • Last reply by perl

more options

I just upgraded to Firefox 79.0, and now the scrollbars on outlook.com are narrow with no scroll buttons. I fixed this problem long ago by setting layout.css.scrollbar-width.enabled to false. It's still set, but now the scrollbars are back to being narrow.

Chosen solution

Support for these layout prefs has been removed in Firefox 79.

  • bug 1641324 - Remove the layout.css.scrollbar-width.enabled and layout.css.scrollbar-color.enabled prefs. [79]

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)


As a workaround you can add this code to the userContent.css file. Add code to the userContent.css file.


*{scrollbar-color:auto!important; scrollbar-width:auto!important;}

It is not that difficult to create userContent.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder".
If you click this button then you open the profile folder in the Windows File Explorer.
You need to create a folder with the name chrome in this folder (name is all lowercase).
In the chrome folder you need to create a plain text file with the name userContent.css (name is case sensitive).
In this userContent.css text file you paste the text posted.
On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userContent.css.txt.
To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userContent.css file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Support for these layout prefs has been removed in Firefox 79.

  • bug 1641324 - Remove the layout.css.scrollbar-width.enabled and layout.css.scrollbar-color.enabled prefs. [79]

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)


As a workaround you can add this code to the userContent.css file. Add code to the userContent.css file.


*{scrollbar-color:auto!important; scrollbar-width:auto!important;}

It is not that difficult to create userContent.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder".
If you click this button then you open the profile folder in the Windows File Explorer.
You need to create a folder with the name chrome in this folder (name is all lowercase).
In the chrome folder you need to create a plain text file with the name userContent.css (name is case sensitive).
In this userContent.css text file you paste the text posted.
On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userContent.css.txt.
To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userContent.css file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Helpful?

more options

That worked. Thank you very much.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.