Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Auto-fill suggests a login that is not saved

more options

I have tried several of the suggested fixes for this issue. I am no longer using an old login for Amazon, and I have tried to clear it as an auto-fill suggestion. However, the login does not appear in the saved logins and passwords section of my settings. I have tried to clear my history, delete all cookies and my cache, and attempted to delete the login from the Amazon login screen, but the login was not in the list of usernames to delete.

Is there something I am missing?

Thank you!

Chosen solution

It dawned on me just a moment ago that I am using a password manager. I went and changed the auto-fill settings in there and it fixed my issue. I apologize for wasting your time.

Read this answer in context 👍 2

All Replies (6)

more options

This could also be saved form data.

Did you try to highlight (select) this item in the drop-down list with the cursor Down key and press "Shift + Delete" ?

Is there a key icon in front of this suggestion in the drop-down list ?

Modified by cor-el

more options

Good morning! I just checked to see if that was possible, and the login that keeps auto-filling does not appear in a drop-down menu at all. The only login visible is the new one that I'm switching over to.

more options

If it is data from Firefox's cache, you may be able to clear it by using Ctrl+Shift+r to reload the page.

If Amazon is auto-filling that field when it serves the page, then you could consider deleting your Amazon cookies. While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

more options

Maybe the website is pre-filling this item, so maybe check the page code.

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious.
If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

more options

Thank you for the possible fixes. Unfortunately, the "Forget About This Site," Shift+Control+r, and the cookie clearing were unable to remove the auto-filled login information. Are there any other steps I could take?

more options

Chosen Solution

It dawned on me just a moment ago that I am using a password manager. I went and changed the auto-fill settings in there and it fixed my issue. I apologize for wasting your time.