Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I click in the address bar, a list of social media and recently visited sites pops up. How do I permanently stop this?

  • 2 replies
  • 1 has this problem
  • 3 views
  • Last reply by ARMAN KHAN

more options

Please take me step by step through the process of making this new, wonderful "feature" disappear and never come back. I find the unwanted pop up (pop down, since it shows below the address bar?) annoying, intrusive (I don't want any suggestions unless I ask for them) and sometimes it covers important information.

TIA

Chosen solution

This can possibly be coming from the Top Sites.
You can try to exclude the "Top Sites".

The location bar drop-down list can show history items, bookmarked pages, pages opened in tabs, top sites, and search suggestions (Options/Preferences -> Search).
You can set what suggestions show when you enter an URL in the location/address bar bar.

  • Options/Preferences -> Privacy & Security
    Address Bar: When using the location bar, suggest:
    History
    Bookmarks
    Open tabs
    Top sites
Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

This can possibly be coming from the Top Sites.
You can try to exclude the "Top Sites".

The location bar drop-down list can show history items, bookmarked pages, pages opened in tabs, top sites, and search suggestions (Options/Preferences -> Search).
You can set what suggestions show when you enter an URL in the location/address bar bar.

  • Options/Preferences -> Privacy & Security
    Address Bar: When using the location bar, suggest:
    History
    Bookmarks
    Open tabs
    Top sites

Helpful?

more options

hello newsletters......

follow the steps:

  • Click the ≡ menu button. and select Options.
  • Select the Privacy & Security panel and scroll down
  • search pop on search bar top
  • disable the pop-up blocker, uncheck the Block pop-up windows box below Permissions.

i have attached screensort for better understand.

tell me its help.

thank you!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.