Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Pop-ups: Firefox keeps forgetting allowed websites

more options

For quite some time now I have to notice that Firefox keeps forgetting the addresses of websites that I have allowed to open pop-ups. I used such a pop-up site just yesterday, the computer has in hibernation over night - and now Firefox blocked opening such a pop-up again, the list of allowed sites is empty.

Chosen solution

Hi berndleutenecker, do other site permissions such as cookie permissions get cleared as well, or only the ones for popups?

You mentioned Windows hibernating: was Firefox in hibernation, too, or was it shut down and then restarted? Just wondering if "Clear history when Firefox closes" could be a factor. That feature has a Settings dialog, and sites' popup permissions may be cleared if the category called "Site Preferences" is selected to clear.

Otherwise, hmm, where are they going?

Read this answer in context 👍 0

All Replies (10)

more options

Chosen Solution

Hi berndleutenecker, do other site permissions such as cookie permissions get cleared as well, or only the ones for popups?

You mentioned Windows hibernating: was Firefox in hibernation, too, or was it shut down and then restarted? Just wondering if "Clear history when Firefox closes" could be a factor. That feature has a Settings dialog, and sites' popup permissions may be cleared if the category called "Site Preferences" is selected to clear.

Otherwise, hmm, where are they going?

Helpful?

more options

Hi, jscher2000!

I do clear cookies when closing Firefox - but I thought (not checked right now) this happens too when I (as I am doing most of the time) just use the Windows- hibernation mode (including Firefox still running with a lot of tabs open) over night.

I do clear the history (German Firefox: Chronik; en: chronicle) when closing Firefox but can't find Popups as part of the settings for that? I've ticked all options apart from 'offline-website-data' (translated from the German version of Firefox). These settings consists of two parts: 'History' (with serveral options, all of them selected) and 'Data'. There I have only selected the German 'Website-Einstellungen' which in my opionen means 'website-settings', not 'Site Preferences' as you wrote? As I didn't know what kind of settings this means, I checked the (German) help page (https://support.mozilla.org/de/kb/neueste-surf-such-und-download-chronik-loeschen?redirectlocale=en-US&as=u&redirectslug=Clear+Recent+History&utm_source=inproduct#w_ihre-chronik-automatisch-laischen-lassen or shorter: https://support.mozilla.org/de/kb/neueste-surf-such-und-download-chronik-loeschen#w_ihre-chronik-automatisch-laischen-lassen) but only when I scrolled further up I found the explanation: popup-settings are part of this settings. So I won't have the 'Website-Einstellungen' (probably 'Site Preferences' in the English version) deleted any more and hope that this solves that rather annoying problem.

Thank you!

Helpful?

more options

I'm glad you were able to find it even with the difference in language.

Helpful?

more options

I have a similar? different? problem. Firefox (W10) is not permitting pop-ups on a whitelisted pop-up website. The pop-up whitelist is *NOT* being erased/destroyed when I shut down (or put the computer to sleep) and continues at all times to be active and entered under options/permissions/block pop-up windows. But that whitelist does not seem to work on this particular website (which is a very trustable website unless its been hacked, which I doubt.

So: how to have a general pop-up prohibition and allow ALL whitelisted websites to insert pop-ups?

I enter this question here because the problem of the prior poster seems so similar and yet different.,

Helpful?

more options

Hi Demogorgon, is Firefox displaying the infobar saying it blocked the popup window? Have you used the button on that infobar to give that site permission to open popup windows, in case that works any better?

Helpful?

more options

If you do not get the info bar then you can look at this pref on the about:config page and reset this pref via the right-click context menu to restore the pop-up info bar at the top:

  • privacy.popups.showBrowserMessage = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

more options

Helpful?

more options

jscher2000 said

I'm glad you were able to find it even with the difference in language.

Well, on another Win10x64-computer Firefox was updated today - and although the setting for deleting the history was and is set as recommended the popup I often need was blocked again (the corresponding infobar was shown and I could add the address with it). Does an update (here 77.x to 78.0.1) delete such exceptions? Or could Sync be the reason? Maybe on another computer (Win7x64 or Win10x64) the address of that specific website is not listed as allowed address and Sync lead to deleting that entry from the computer I am using right now?

Regards

Bernd Leutenecker

Helpful?

more options

Exceptions aren't part of syncing data, you normally only lose exceptions if you clear (lose) the Site Preferences.
Did you check the exceptions for pop-ups in "Options/Preferences -> General" "Options/Preferences -> Privacy & Security -> Permissions -> Block pop-up windows -> Exceptions" ?

Modified by cor-el

Helpful?

more options

As I am using the German GUI-version of Firefox and can't find pop-up-settings under 'General'!?

I hope I am using the same option as you meant:

After opening the menu (three horizontal bars on the top-right side) I click on 'Einstellungen' = settings.

If I open 'Allgemein' = general from the left-side menu I can't find settings for pop-ups.

Instead, from the left-side menu I choose 'Datenschutz & Sicherheit' = privacy and security.

I scroll down to 'Chronik' = history with these settings:

'Firefox wird eine Chronik nach benutzerdefinierten Einstellungen anlegen' = Firefox will save a history (timeline) following user-defined settings.

'Die Chronik loeschen [with German Umlaut: löschen], wenn Firefox geschlossen wird' = delete the history when Firefox is closed.

There I have this 'Einstellungen' - settings:

Firefox will delete automatically:

'Chronik' = history or timeline:

'Besuchte Seiten & Download-Chronik' = visited sites and download-history

Cookies

Cache

'Aktive Logins' = active logins / logons

'Eingegebene Suchbegriffe & Formulardaten' = entered search-terms and form-data/form-contents

'Daten' = Data:

No option selected.

Before the recommendation of jscher2000 I had activated the option to delete 'Website-Einstellungen' = website-settings.

Furthermore I have activated the option to block pop-up-windows and added an exception for the website I often use in 'Datenschutz & Sicherheit' = privacy and security. And that's the problem: After the update from v77.x to v78.0.1 the exception was missing again ...

Modified by berndleutenecker

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.