Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Do not close popups on switch language

  • 2 replies
  • 1 has this problem
  • 6 views
  • Last reply by cor-el

more options

Hi, When open popups (Extension popup) some of these have input field, like as Bitwarden which need to enter the master password, Most of time I should/need change keyboard language to write correct text/password, But when use Super+Space to change the language popup got closed and gone. I checked Chromium and it does not close the popup on something like this. Also its not specified to Bitwarden extension, these is some other extensions like Clockify, Google translate and more...

All Replies (2)

more options

I may be mistaken, but I believe this happens because the add-ons get restarted by the browser when there's a language change so that they can change their language as well. That would cause any pages that belong to the extension to be closed.

Unfortunately, there's probably not a lot that can be done on this forum. You should probably report it as a bug using the bugzilla(dot)mozilla(dot)org website so that the Firefox developers can address the issue.

NOTE: Due to some spam on the forums, posting links is currently restricted, so I had to substitute the dots in the link with (dot) in order for the forum to allow me to post it.

Modified by Wesley Branton

Helpful?

more options

Maybe switch the Linux keyboard layout before opening the pop-up.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.