Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird constantly causing error: Too many SMTP connections

  • 6 replies
  • 1 has this problem
  • 45 views
  • Last reply by marcus12

more options

This topic (or those of a similar nature) have been popping up for years. I have reviewed the archived threads and this seems to be something new.

This error started popping up on my screen about a week ago for no explicable reason. I made no changes to my email accounts, no changes to the setup of Thunderbird, I was just getting on with my work and Thunderbird started throwing up this error and refusing to send my emails.

Following past solutions, I delete all stored passwords in Thunderbird's "Saver Passwords...". Shut down Thunderbird and restart the program. Thunderbird then asks for the email account password on startup (to log into the IMAP server). I enter the password and check the "Use Password Manager..." and click OK and all seems okay. I go to a message that I want to reply to and hit "reply". Type the reply and hit send. Thunderbird asks for the email account password to log into the SMTP server which I enter and check the "Use Password Manager..." and click OK. Thunderbird then send this first reply. But from this point on the error message comes up every subsequent time I try to send or reply to an email.

The work around is to go back and delete all stored passwords again.

Does anyone have any more information on this? Is there an existing solution that I have overlooked?

All Replies (6)

more options

Something just changed....

After using my work around (detailed in the OP), now TB doesn't even ask for the SMTP server password before the error "Too many SMTP connections" error pops up on my screen. Now I can send or reply to any emails.

The cause of this error is proving to be impossible to pin down.

Helpful?

more options

Rename the password storage file in the profile there is a fair chance is has become corrupt in some manner. The file is called signons.sqlit and you should probably also rename the ket3 file as it holds the encryption key of signons.

Restart Thunderbird and see if things improve.

This is a hit an miss response. it might not do anything, but it is good to eliminate corruption first thing. The error message itself is a bit of a concern as it does not appear to have anything to do with passwords. But we will see I suppose.

Helpful?

more options

I solved my particular version of this problem but there is still work to be done.

Solution: Running deeper error checking through my webmail portal, it turns out that the password authentication was failing (intermittently). That put me on the right path to solving this problem. My hosting account provider deleted the MX records associated with the account during a systems maintenance or upgrades. The intermittent nature of this error was caused by "echos" of the MX records surviving on web which were slowly disappearing.

The extra work that TB needs is better error reporting. Looking back over the history of posts on "error: Too many SMTP connections... " this seems to be some kind of default message that has popped up for many reasons. My webmail portal was able to do a better job of reporting on the error that was occurring. TB should have been able to identify that the login process was failing and "error: Too many SMTP connections" does not suggest that login failure is the fundamental issue.

Helpful?

more options

@Matt - a top suggestion based on the error message. As you can see, you were typing your response as I was typing the solution (in this case). Given the generic nature of the error message, anyone coming across this error is going to have to try multiple possible solutions. At least, until the error handling of TB improves.

Helpful?

more options

So this is a DNS issue and is caused by DNS replication. So Thunderbird was probably being connected to your old server which considered one connection to many because you account was closed. These are not ghosts or echos, they are lags on DNS replication. I would actually put money on the error you received being exactly what the server Thunderbird tried to connect to replied with.

Helpful?

more options

@Matt - Yes, when I use the plain language description of echos I do mean lags in DNS propagation which, again to use plain language, leave "ghosts" of the MX records across the network of DNS.

But to get to the point about TB's error handler reports, TB returned: "An error occurred while sending mail: The mail server sent an incorrect greeting: Too many concurrent SMTP connections; please try again later.."

CLIENT -> SERVER: EHLO returns: "SMTP ERROR: EHLO command failed: SMTP NOTICE: EOF caught while checking if connected SMTP Error: Could not authenticate. SMTP Error: Could not authenticate.

When you know that there is an SMTP authentication error you don't just go back and try later. The EHLO error report provides a clear understanding of what further investigation needs to be done.

So, it would be good if one of the developers could take a good look at TB's error handler. To users, TB is a wonderful and very stable product. If you see a message like this don't assume TB is at fault. You should check if another mail client has a problem with the email hosting as well.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.