Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not loading Google Fonts on a Mac

  • 3 replies
  • 1 has this problem
  • 37 views
  • Last reply by waveman777

more options

Hi everyone.

I'm experiencing problems with Firefox. It's not loading Google Fonts. I'm on a MacBook Pro 2015, latest Catalina Mac OS, latest Firefox 77.0.1.

My particular problem regards "Amatic SC" Google Font: link text

but not only this one. Other fonts are not loading properly either. Here is a jsfiddle I created with a simple code to test it on other platforms:

link text

I tested it on Firefox on Windows 10, Windows 7 as well as on Chrome, Safari and Opera for Mac. All load and display Amatic SC font properly, but Firefox on a Mac is not doing it.

Instead loading Amaric SC, Firefox is showing default Apple Chancery font.

I tried clearing cache, reinstalling, non of it works.

Please help me to figure this out. Thanks

Attached screenshots

Chosen solution

Hi waveman777, I don't why Firefox would work differently on Windows 10 vs. MacOS. Could you try:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like June2020, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem fonts work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (June2020 will remain available for future testing.)

IMPORTANT: Creating a new profile may change your default. If your regular profile has a Set as Default Profile button after this test, click that to make sure your next startup doesn't yield a surprise.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Hi waveman777, I don't why Firefox would work differently on Windows 10 vs. MacOS. Could you try:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like June2020, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem fonts work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (June2020 will remain available for future testing.)

IMPORTANT: Creating a new profile may change your default. If your regular profile has a Set as Default Profile button after this test, click that to make sure your next startup doesn't yield a surprise.

Helpful?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.

Helpful?

more options

@jscher2000

Thanks! This helped me to pinpoint the issue. After creating new profile all started to work, so I completely removed Firefox along with all files inside the system, and reinstalled it again, then logged in to my account, and after Firefox installed all extensions and download bookmarks, all started to work just fine.

I appreciate your help! Thanks

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.