Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Recent Difficulty with Google products using Firefox

  • 3 replies
  • 1 has this problem
  • 4 views
  • Last reply by paulie0701

more options

Recently I have experienced difficulty loading gmail when using firefox, and then from a gmail inbox page, clicking their 9 dots (right top corner), selecting google drive, which now opens a blank tab and fails to load anything. This problem has only occurred since the most recent update with firefox.

I am using 77.0.1 (64-bit) on Mac OS - MoJave v10.14.5 - I do NOT experience these issues when using Chrome browser, or using Firefox on my Linux system.. only on my Mac.

Additionally, despite clearing all cache, history, etc. etc. several times, the problem persists, though sometimes, it does actually work, but rarely, compared to never having this problem.

In the bottom left corner where google hangouts crap is, it often shows a 301 error, obviously trying to re-direct something, but always fails, and hence, the full page never fully loads.

Screenshots attached: 1. gmail inbox page - loading issue as noted regarding bottom left corner with regards to hangouts stuff. 2. capture of tabs after clicking to select Google Drive from within the Gmail page as noted.

Hope this info helps - Thanks for any efforts to rectify this annoying issue, as I really don't want to resort back to Chrome.

Attached screenshots

Chosen solution

Hi paulie0701, it sounds like you have done nearly all of the standard troubleshooting already. Here are two other steps we often recommend:

Firefox's Safe Mode

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like June2020, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (June2020 will remain available for future testing.)

IMPORTANT: Creating a new profile may change your default. If your regular profile has a Set as Default Profile button after this test, click that to make sure your next startup doesn't yield a surprise.

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Hi paulie0701, it sounds like you have done nearly all of the standard troubleshooting already. Here are two other steps we often recommend:

Firefox's Safe Mode

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like June2020, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (June2020 will remain available for future testing.)

IMPORTANT: Creating a new profile may change your default. If your regular profile has a Set as Default Profile button after this test, click that to make sure your next startup doesn't yield a surprise.

Helpful?

more options

Thanks jscher2000 for your detailed and helpful response. Your instructions were easy to follow, thank you again, and while some other things went wrong during the process (not your fault), the problem seems to have been rectified once a new profile had been created, and a complete restart was executed.

Annoying that I had to set up things again, but better than the on-going annoyance of the initial problems.

Hope things remain stable now.

Thanks

Helpful?

more options

Having said all that, the problems continue to persist :(

Anyway.. if it continues, I'll just have to go back to using Chrome.. Sad times..

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.