Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Windows Cannot Find Firefox.exe

  • 14 replies
  • 4 have this problem
  • Last reply by jscher2000

more options


I've been using firefox for a while on this computer now, but this morning I was hit with a popup saying: "Windows cannot find 'C:\Program Files\Mozilla Firefox\firefox.exe'. Make sure you typed the name correctly, and then try again."

I have so far tried every fix I can find (which aren't many for this glitch), and none have worked. I have tried uninstalling and deleting all folders related to Firefox, and the new install still gives me the same error. My OS is Windows 10, and I have not had any problems with Firefox before this morning, nor have I made any changes to the files or anything of the sort. Just tried to run it and it gave me this.

I am at my wits end a bit with this. Help!

Chosen solution

Here is another key you can check:

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options => Debugger


Read this answer in context 👍 2

All Replies (14)

more options

Hi killtoy, please ignore the spam message with a phone number -- that's not official and we don't know what they will do to your system if you engage.

more options


You may have seen a post or received a notification regarding support for Firefox or Thunderbird with a link to another site or a phone number being posted. This is a scam and is not a method to receive support from Mozilla. Mozilla does not have telephone or email support. Please do not click on the link and do not interact by calling any phone numbers or email addresses listed. I apologize for any inconvenience caused. You are currently posting on the official Mozilla website and will receive assistance here.

more options

Hi killtoy, coincidentally (??) a user who appears to have a non-English language Windows reported that error this morning. On that computer,

C:\Program Files

was spelled differently. Do you have that same situation or does that exact path in the error message exist on your computer?

C:\Program Files\Mozilla Firefox\

Other thread (unsolved):

more options

There are now 3 of these reported problems.

FredMcD said

See if this works ( notice the quotes front and back ) : "C:\Program Files\Mozilla Firefox\firefox.exe"
more options

Another user reported that moving the contents of:

C:\Program Files\Mozilla Firefox


C:\Program Files (x86)\Mozilla Firefox

allowed Firefox to run. I don't know why that would make a difference.

more options


Thank you jscher2000, moving the program folder from Program Files to Program Files (x86) did indeed work!

more options

Hi killtoy, it makes me a bit suspicious if programs can't run from the normal 64-bit programs folder. What is going on there?

more options

Could this be a problem with the Windows Registry in the key where these default Shell Folders locations are stored ?

  • HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
more options

Chosen Solution

Here is another key you can check:

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options => Debugger


more options


1st: jscher2000: Honestly, I have no idea. Haven't made any changes to my computer at all, it just stopped working. And I honestly don't know why moving the folder fixed it.

And on that note, the same error popped up on my sister's computer this morning too, and the same fix worked, so thank you for that.

2nd: cor-el: Thank you for that. I do have Avast, and Avast Cleanup, both of which I use frequently. If I run into the error again, I'll let you know if that fixes it.

Would be really annoying if it's Avast breaking file links and registry. -_-

more options

Me again!

So, been struggling with the same error while trying to open Microsoft Word and all related files. I did the fix you suggested, Cor-el, and it worked. Turns out the problem is Avast Cleanup rewriting the value in a program's debugging registry. Simply deleting the Avast value fixes the issue.

Thank you guys so much for the help and your speedy replies, I would never have found the root of the issue or its fix without you. :)

Modified by killtoy

more options

Well done. You should contact Avast support and let them know.

more options

There seem to be a lot of reports on so we're just waiting for Avast to issue a fix.

more options

Avast has issued an update for Avast Cleanup that should fix this: