Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to connect to Google.com after Windows update of Edge.

  • 7 replies
  • 1 has this problem
  • 49 views
  • Last reply by imthi_

more options

My windows recently got updated with the new edge update (KB4559309), and ever since then I've been unable to connect to Google.

  • Other websites and browsers work. The issue seems to be with google.com on Firefox.
  • I'm not running any third party antivirus software
  • Time settings are correct
  • I cannot uninstall the latest update (which I believe to be the cause of the issue, as it started after that update)
  • Ran antivirus scans to see if there's any malware on my side
  • Tried resetting all browser options
  • and there's no option to bypass the warning

I would really appreciate any help on this, as I cannot get any work done as having to switch to another browser sort of slows me down a lot as I'm so used to Firefox.


https://www.google.com/search?client=firefox-b-d&q=help

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: true HTTP Public Key Pinning: true

Certificate chain:


BEGIN CERTIFICATE-----

MIIDcjCCAlqgAwIBAgIQFfORP+GRbKdO8QVKYEiRTzANBgkqhkiG9w0BAQsFADAj MSEwHwYDVQQDDBhEaWdpQ2VydCBHbG9iYWwgUm9vdCBHMUEwHhcNMTkwNjA4MTg0 NTE0WhcNMzAwNjA4MjM0NTE0WjAZMRcwFQYDVQQDDA53d3cuZ29vZ2xlLmNvbTCC ASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEBAOfTVTkuVSvgBH4mQ4Nc+kO9 QJBPeT8lhuanXIeT/fuLHHrlcrCDpgBHNqlMxhGRnM538vO0KRVKTW0ttQQ5KxSZ qi1YeJz+d7wv0zAY8FZYA2nR8hkECmmL7niXPZQ0H1VS0TFt2Ek+4C3ZfDXINK3X qpB6gK0myYxMKv7pkO2GICor+3se8iEK2EzkjUK/snd0ib43GH4D7P5Auu7/iEv7 0aI6VwcWZLm1DQwW5tG/mpaRu2DpyK7hDq5VL85tR/OdXrJXILAuSSDpJsm5Kx6y RDvameeOk3x9LtJ6C+uP964SRX/O7We/uWX1JbkSB7+bwg5mMbLcqDaVcEbq87kC AwEAAaOBqzCBqDATBgNVHSUEDDAKBggrBgEFBQcDATAMBgNVHRMBAf8EAjAAMA4G A1UdDwEB/wQEAwIFoDAzBgNVHREELDAqgg53d3cuZ29vZ2xlLmNvbYIMKi5nb29n bGUuY29tggpnb29nbGUuY29tMB8GA1UdIwQYMBaAFE0N/J5wvZXbEmxysCYJtyZ+ I7JnMB0GA1UdDgQWBBT1f9959vs71AAdrIp6ThwPj70XtzANBgkqhkiG9w0BAQsF AAOCAQEAPbwkM4LksI1drlogaQlcBHgpEy0v3RTKeRxEi+hhtAyV7yyxMChEx40H VsbehKFcthQk2rVykbGYuu3sg1LeeEYCvEROGy3zMc3tzQxjKyDsArtEw95wG8TW Qe4apd/ogWKKOe5WsM+SPHTLYtYhlVPfbQaK4N3bimSE9WOckqG7PqRD6q4F+REY e/Y5x6b4rCug/KI89csDyeYGdwtVYFmwl8NEBbiVbY658iQ5HeNg9ZCkHsJ68553 SMU4BOrAHqzkqmAwcFPylDsOSWVKEnnebtIZrGLxos20R6pJ42SxZHwVh7DzFodN q62nP/no5qE7+2puFsO66hOUAKWBaw==


END CERTIFICATE-----

Chosen solution

jscher2000 said

Hi imthi_, that's not the real certificate for google.com, but unfortunately it doesn't point to a particular "man in the middle" causing this problem. Do you think the Windows update might have changed anything about your connection, such as:
  • different DNS servers
  • different proxy server settings
  • change to VPN if you use one
Perhaps try some supplemental malware scans to see whether anything has crept in: Troubleshoot Firefox issues caused by malware.

I think I solved it! In network settings, it had the option "Use system proxy" enabled I switched it to "No proxy" and now I can connect to Google.com

I do believe it's an update issue, as I was using it perfectly until i had to do an update restart at which point I could no longer connect to Google.

Thank you for the help!

Read this answer in context 👍 1

All Replies (7)

more options

Hi imthi_, glad to see you on Mozilla Support Forum.

Try Refreshing your Browser:-

  • To do this, click the menu button at the top right corner of the Firefox window.
  • Click the “Help” option near the bottom of the menu.
  • Click the “Troubleshooting Information” option in the Help menu.
  • Click the “Refresh Firefox” button at the top right corner of the Troubleshooting Information page.
  • You’ll be warned that this will remove your browser add-ons, reset your customizations, and revert other browser data to the default settings. Click “Refresh Firefox” to confirm you want to make these changes.

If it doesn't solved your problem, then feel free to ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

Modified by Shashank Shekhar

Helpful?

more options

Shashank Shekhar said

Hi imthi_, glad to see you on Mozilla Support Forum. Try Refreshing your Browser:-
  • To do this, click the menu button at the top right corner of the Firefox window.
  • Click the “Help” option near the bottom of the menu.
  • Click the “Troubleshooting Information” option in the Help menu.
  • Click the “Refresh Firefox” button at the top right corner of the Troubleshooting Information page.
  • You’ll be warned that this will remove your browser add-ons, reset your customizations, and revert other browser data to the default settings. Click “Refresh Firefox” to confirm you want to make these changes.
If it doesn't solved your problem, then feel free to ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

Thanks for the reply, but unfortunately I still get the same "Did Not Connect: Potential Security Issue"

Helpful?

more options

Sorry For that,

Maybe this 3 Minute Video will help you:-

https://www.youtube.com/watch?v=gHFw9NXndls

Helpful?

more options

Hi imthi_, that's not the real certificate for google.com, but unfortunately it doesn't point to a particular "man in the middle" causing this problem. Do you think the Windows update might have changed anything about your connection, such as:

  • different DNS servers
  • different proxy server settings
  • change to VPN if you use one

Perhaps try some supplemental malware scans to see whether anything has crept in: Troubleshoot Firefox issues caused by malware.

Helpful?

more options

Shashank Shekhar said

Sorry For that, Maybe this 3 Minute Video will help you:- https://www.youtube.com/watch?v=gHFw9NXndls

I've tried following that tutorial to no avail.

Helpful?

more options

jscher2000 said

Hi imthi_, that's not the real certificate for google.com, but unfortunately it doesn't point to a particular "man in the middle" causing this problem. Do you think the Windows update might have changed anything about your connection, such as:
  • different DNS servers
  • different proxy server settings
  • change to VPN if you use one
Perhaps try some supplemental malware scans to see whether anything has crept in: Troubleshoot Firefox issues caused by malware.

This might seem like a dumb question, but I did an ipconfig/all and for my DNS server it shows a string of letters and numbers followed by what looks like a normal IP (192.168.x.x) on a second line. Is that normal? (can provide a picture of the DNS if you'd like) I don't use a proxy but I can double check (need to search up how to do that) and I do not use a VPN.

Helpful?

more options

Chosen Solution

jscher2000 said

Hi imthi_, that's not the real certificate for google.com, but unfortunately it doesn't point to a particular "man in the middle" causing this problem. Do you think the Windows update might have changed anything about your connection, such as:
  • different DNS servers
  • different proxy server settings
  • change to VPN if you use one
Perhaps try some supplemental malware scans to see whether anything has crept in: Troubleshoot Firefox issues caused by malware.

I think I solved it! In network settings, it had the option "Use system proxy" enabled I switched it to "No proxy" and now I can connect to Google.com

I do believe it's an update issue, as I was using it perfectly until i had to do an update restart at which point I could no longer connect to Google.

Thank you for the help!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.