Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not load *.google.com but google.de, not issues in other browser

  • 5 replies
  • 1 has this problem
  • 57 views
  • Last reply by virtualize

more options

Latest Firefox 63.0 OSX High Sierra 10.13.6 (17G65) - no antivirus scanner - not on a corporate network - no proxy servers in Firefox or OSX

https://google.com/ > Unable to connect https://groups.google.com/ > Secure Connection Failed https://calendar.google.com/ > Secure Connection Failed https://maps.google.com/ > Secure Connection Failed https://mail.google.com/ > Unable to connect https://drive.google.com/ > Unable to connect

These do load without problems: https://www.google.de/ https://www.google.at/ as well as any other website I've tried

What I've tried so far: - Safe Mode - Firefox Refresh - complete removal of Firefox and profile, re-download, fresh install - switching between wifi and cable connections

No other browser on my system has these issues, testet with Safari, Chrome, Vivaldi

I do remember having this issue on 62.0.3 too...

Thanks for any pointers.

Chosen solution

Hi There! I was running into the same problem you're describing with Firefox on macOS. Everything loads fine except google.com sites, and google.com sites loading perfectly fine in all other browsers. In my case, it turned out to be a rule I had set (deliberately or not, I'm not certain) in Little Snitch (a macOS firewall app) that was blocking all outgoing connections from Firefox to google.com. I have no idea if you're running Little Snitch or something similar, but I wanted to pass along my solution just in case it was helpful.

Oh Boy. Thats it! My Little Snitch Firewall had a rule blocking all *.google.com Problem solved. Thanks a lot.

Read this answer in context 👍 0

All Replies (5)

more options

Hallo virtualize:

I have almost the identical setup: Mac OS X 10.13.6, 2015 13" Mac book Pro but I'm in Canada.

For me all google sites work, *.google.com, google.at, google.de, etc

Please check your DNS settings (try Google's DNS and see if that helps;ask a tech savvy friend if you can't figure out how to do this please! sounds like you know lots though !) and your ISP and your firewall if you have one.

We've had many instances in the past where a Canadian ISP, telus, broke Firefox but not Chrome, Safari or Edge

Cheers!

...Roland

Modified by Roland Tanglao

more options

Hi Roland, thanks for the reply.

Changing the ISP did not matter. I've tried 3 different german ISPs (Vodafone, O2, 1und1). The behavior is the same as described above.

Changing the DNS servers to Google's (8.8.8.8 / 8.8.4.4) however did result in Firefox not loading any page at all. But again no problems in all other browser... Hm.

more options

Chosen Solution

Hi There! I was running into the same problem you're describing with Firefox on macOS. Everything loads fine except google.com sites, and google.com sites loading perfectly fine in all other browsers. In my case, it turned out to be a rule I had set (deliberately or not, I'm not certain) in Little Snitch (a macOS firewall app) that was blocking all outgoing connections from Firefox to google.com. I have no idea if you're running Little Snitch or something similar, but I wanted to pass along my solution just in case it was helpful.

Oh Boy. Thats it! My Little Snitch Firewall had a rule blocking all *.google.com Problem solved. Thanks a lot.

more options

Fantastic virtualize. I did ask you to check your firewall didn't I :-) I guess it's easy to forget this things like firewalls that run in the background!

But who cares, glad you got it working!

Cheers!

...Roland

more options

Ah, yes you did. Guess I've overlooked it, while I was so obsessed to check DNS and ISP :)