Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot open a particular website

more options

There is one particular website domain that just will not open with Firefox, but will open with Internet Explorer (which I don't want to use). All other websites/domains open just fine in Firefox.... what the heck? Help would be appreciated. Using latest version of Ff browser and a Sony laptop computer.

Chosen solution

Yes, unfortunately they don't provide a lot of controls. Take it or leave it, I guess?

Read this answer in context 👍 0

All Replies (20)

more options


Clear all cookies, site data and cache

  • Click the menu button. and select Options. Preferences.
  • Select the Privacy & Security panel and go to the Cookies and Site Data section.
  • Click the Clear Data… button. The Clear Data dialog will appear. ...
  • Click Clear.

If it doesn't solved your problem, then feel free to ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

more options

Already tried clearing cookies, site data and cache and did not help...

more options

Hope this article will help you Firefox can't load websites but other browsers can .


more options

Hi thomasgreatheart, if the above doesn't help, could you describe in more detail what happens when you try to open that address? For example:

  • error message -- what does it say? feel free to copy/paste
  • blank page
  • blank page after a login page
  • partial load, like unstyled HTML text, or blank regions within the page
  • something else
more options

The web address appears in the address bar at top of page. The rest of the page is totally blank. No error messages or anything else.

more options

thomasgreatheart said

The web address appears in the address bar at top of page. The rest of the page is totally blank. No error messages or anything else.

Could you open the Network Monitor tool in the lower part of that tab -- either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Ctrl+Shift+e

Then click in the address bar and press Enter to trigger a reload, or press Ctrl+Shift+r. In the Network Monitor, Firefox should start listing all the files it is requesting, along with information about whether the request was successful -- usually a 200 or 304 in the left column. Do you see any activity there?

more options

Here's what I got:

Status: 200 Method: GET Domain: Initiator: document Type: html Transferred: 750 B Size: 920 B 0 ms: 220 ms

1 request 920 B / 750 B transferred Finish: 220 ms DOMContentLoaded: 763 ms load: 999 ms

more options

920 bytes is not very many characters but you should see at least a little something, unless it's just a bunch of instructions to move on to the next thing.

What normally happens with this address: does it redirect to another page, or login, etc.?

You may want to make sure the redirect block is turned off:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste access and pause while the list is filtered

(3) If the accessibility.blockautorefresh preference has a value of true, double-click it to restore the default value of false

more options

What normally happens with this address: does it redirect to another page, or login, etc.?

It just opens the webpage which is a digital online newspaper -- no login, no redirect, etc.

I have no issue opening ANY other webpage, so don't know why the redirect block would have anything to do with it...? But I am not that knowledgeable about it, so ?

more options

I see why the page only has 920 bytes, it basically is a frame which loads the site from a different server.

What if you right-click in the center of the blank page, then expand This Frame, then click Reload Frame. Does anything load?

more options

Tried it -- page remains blank

more options

Could a blocker be coming into play?

Double-check content blockers: Firefox's Content Blocking/Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a purple shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Enhanced Tracking Protection in Firefox for desktop (before Firefox 70: Content blocking).

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

I restarted Firefox in safe mode, and the website (e-newspaper) loaded. So how do we figure out which add-ons are blocking webpage?

more options

Do you have content blocking extensions ?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
more options

Some of your extensions probably block content intentionally, whether for security, privacy, or simply annoyance-related reasons. Those are all suspects. If they have toolbar buttons, you can check them to see whether they have an option to make an exception for the current page, and whether that allows the frame to load. If they have an all-or-nothing design, you may need to individually disable them on the Add-ons page for testing.

more options

Thanks, but I don't really know what "extensions" are, or how to check them -- can you give more specific instructions for dummies?

more options

Did you read the article or is that still not clear ?

more options

I disabled DuckDuckGo privacy essentials, and the website loads, however, I don't see a way to make an exception for this webpage in privacy essentials add-on.

more options

Chosen Solution

Yes, unfortunately they don't provide a lot of controls. Take it or leave it, I guess?

more options

Okay, well thank you for all your help - maybe I will try reaching out to DuckDuckGo and see what they suggest.

  1. 1
  2. 2