Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Browser close without warning

  • 5 replies
  • 1 has this problem
  • 47 views
  • Last reply by AliceWyman

more options

By closing the browser he quite without a warning, despite I checked the "warn when browser is closing" box checked box in picture (german installation)

Attached screenshots

Chosen solution

Reinstalling Firefox won't help. Firefox closes without warning by default, when you close the last tab. The check box to warn you when quitting the browser in the Firefox General panel under Startup is for when "Restore previous session" is enabled, to warn you when closing Firefox with multiple tabs open.

You should go to about:config and reset the browser.tabs.warnOnClose preference back to true (the default setting) so you are warned when closing Firefox with multiple tabs open if you later disable the "Restore previous session" Startup option.

You can try this solution, from https://support.mozilla.org/en-US/questions/1205166#answer-1077652

In about:config, find the preference browser.tabs.closeWindowWithLastTab and set it to false.

I tested in Firefox 77 on Windows 7 by setting this preference to false. When I tried to close the last tab, Firefox opened the New Tab page. To close Firefox, I had to use the X at the top of the window or go to the Firefox 3-bar menu and click Exit.

Read this answer in context 👍 0

All Replies (5)

more options

Please ignore foxhelp221's post and don't call that number   -   it's a scam !

Helpful?

more options

Hello,

You may have seen a post or received a notification regarding support for Firefox or Thunderbird with a link to another site or a phone number being posted. This is a scam and is not a method to receive support from Mozilla. Mozilla does not have telephone or email support. Please do not click on the link and do not interact by calling any phone numbers or email addresses listed. I apologize for any inconvenience caused. You are currently posting on the official Mozilla website and will receive assistance here.

Helpful?

more options

Hello,

Type about:config<enter> in the address bar. If a warning screen comes up, press the Accept the risk and Continue button. At the top of the screen is a search bar. Type browser.tabs.warnOnClose and set it to true.

Hope it helps. Thank You.

Helpful?

more options

@ Shashank Shekhar I set the browser.tabs.warnOnClose option from false to true, but it doesnt work. So I think I have to reinstall th browser to solf the problem

Helpful?

more options

Chosen Solution

Reinstalling Firefox won't help. Firefox closes without warning by default, when you close the last tab. The check box to warn you when quitting the browser in the Firefox General panel under Startup is for when "Restore previous session" is enabled, to warn you when closing Firefox with multiple tabs open.

You should go to about:config and reset the browser.tabs.warnOnClose preference back to true (the default setting) so you are warned when closing Firefox with multiple tabs open if you later disable the "Restore previous session" Startup option.

You can try this solution, from https://support.mozilla.org/en-US/questions/1205166#answer-1077652

In about:config, find the preference browser.tabs.closeWindowWithLastTab and set it to false.

I tested in Firefox 77 on Windows 7 by setting this preference to false. When I tried to close the last tab, Firefox opened the New Tab page. To close Firefox, I had to use the X at the top of the window or go to the Firefox 3-bar menu and click Exit.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.