Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Battery drains quickly on Windows

  • 6 replies
  • 1 has this problem
  • 2271 views
  • Last reply by Omkar

more options

Firefox is really nice browser which I am using for more than a decade on my Ubuntu machine. But on Windows machine its battery performance is very poor as compared to Chrome. Firefox almost swallows the whole battery in 1/3rd of the time as compared to Chrome. It is very much consistent on Windows machine. I tried usual tricks of uninstall/install, disabling of add-ons etc. It doesn't seem to be my environment issue. Facing this issue since last year when I resumed using Windows. This is preventing from using Firefox on Windows and eventually on all platforms. Appreciate any help/hints. Thanks!

Firefox is really nice browser which I am using for more than a decade on my Ubuntu machine. But on Windows machine its battery performance is very poor as compared to Chrome. Firefox almost swallows the whole battery in 1/3rd of the time as compared to Chrome. It is very much consistent on Windows machine. I tried usual tricks of uninstall/install, disabling of add-ons etc. It doesn't seem to be my environment issue. Facing this issue since last year when I resumed using Windows. This is preventing from using Firefox on Windows and eventually on all platforms. Appreciate any help/hints. Thanks!

Chosen solution

Omkar said

Compositing Direct3D 11 (Advanced Layers)

Try to enter about:config, then set gfx.webrender.all = true and restart the browser.

Read this answer in context 👍 1

All Replies (6)

more options

Can you enter about:support in the URL bar and tell us, what's under the Graphics section in the Composing line?

more options

Hello,

Have you tried Firefox in Safe Mode? Please do.

Try opening firefox in Safe mode,

  • Find the Firefox icon or click Start and type Firefox.
  • Hold down the Shift key on the keyboard and then click the Firefox icon.
  • In the Firefox Safe Mode window, click the Start in Safe Mode option.

After that,

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode; Free Online Encyclopedia

Hope it helps. Thank You.

Modified by Shashank Shekhar

more options

@TyDrainu,

  Thanks for the reply.

Following is the value for Graphics -> Compositing

Compositing Direct3D 11 (Advanced Layers)

Thanks

more options

. Firefox Is Faster and Leaner Than Chrome. Everything changed with the release ... In a 2018 battery test, Microsoft showed that its Edge browser lasted 60 percent longer ... Slow (But Other Browsers Run Fast) If Firefox feels slow compared to other ...


https://www.makeuseof.com/tag/switch-chrome-firefox/

Thank you

more options

Chosen Solution

Omkar said

Compositing Direct3D 11 (Advanced Layers)

Try to enter about:config, then set gfx.webrender.all = true and restart the browser.

more options

TyDraniu said

Try to enter about:config, then set gfx.webrender.all = true and restart the browser.

With this change, I could see significant improvement in power usage from Firefox. I think this property should have been set by default in browser.

Thanks for the help!