Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How to Remove Addresses from Suggestions in Address Bar

more options

Every time I click the address bar (to type an address) FF shows me a list of links (see the attachment) which I can't get rid of. I tried shift+del solution which does nothing. Also I cleaned up my history and bookmarks (I searched and deleted everything related to those addresses). Can someone please let me know how to get rid of this suggestions?

Attached screenshots

Chosen solution

OK, managed to get rid of old ones from the list, thanks to @jscher2000 pointing out the name of the feature. I removed them from the "Top Sites" section in the "Home Page" (the one shown in the new tab). Thanks.

Read this answer in context 👍 0

All Replies (11)

more options

Please go to Hamburger Menu -> Options -> Privacy & Security (or type about:preferences#privacy in the address bar), scroll down to Address Bar section and uncheck every option (screenshot).

Helpful?

more options

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Helpful?

more options

Hi rad.wildrydes.d2ecf5, these are not the kinds of suggestions configured on the Preferences page that are matches to what you typed. This is something recent.

When you click in the address bar in Firefox 76, by default, it drops down a list of your first 8 "Top Sites" from the Firefox Home / new tab page. They should look familiar if you use the Firefox Home / new tab page; otherwise not so much.

So, you have choices:

(A) Curate the Top Sites and keep using that list if it's useful

(B) Disable Top Sites and use the frequently used pages list if it's useful

Preferences page > Home panel > Firefox Home Content, uncheck the box for "Top Sites" and the drop-down will usually show the classic "frequently used pages" list instead

(C) Turn off the automatic dropping down (i.e., the way Firefox 74 worked when you clicked in the bar)

Here's how: there is a preference for now... possibly to be removed later:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.openViewOnFocus preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

Helpful?

more options

Elysium said

Please go to Hamburger Menu -> Options -> Privacy & Security (or type about:preferences#privacy in the address bar), scroll down to Address Bar section and uncheck every option (screenshot).

Not sure if this really a solution. It's more of eliminating the problem. But didn't work anyway. Thanks.

Helpful?

more options

cor-el said

If you use Sync then best is to disconnect Sync temporarily during troubleshooting. You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.
  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page
If errors are reported with "Verify Integrity", close and restart Firefox and retry. If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.
  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created
See also: You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Thanks for the reply. Verified and everything is fine:
+ The places.sqlite database is sane
+ The favicons.sqlite database is sane
> Task: invalidateCaches
+ The caches have been invalidated
> Task: checkCoherence
+ The database is coherent
Nothing changed :(

Helpful?

more options

jscher2000 said

Hi rad.wildrydes.d2ecf5, these are not the kinds of suggestions configured on the Preferences page that are matches to what you typed. This is something recent. When you click in the address bar in Firefox 76, by default, it drops down a list of your first 8 "Top Sites" from the Firefox Home / new tab page. They should look familiar if you use the Firefox Home / new tab page; otherwise not so much. So, you have choices: (A) Curate the Top Sites and keep using that list if it's useful (B) Disable Top Sites and use the frequently used pages list if it's useful Preferences page > Home panel > Firefox Home Content, uncheck the box for "Top Sites" and the drop-down will usually show the classic "frequently used pages" list instead (C) Turn off the automatic dropping down (i.e., the way Firefox 74 worked when you clicked in the bar) Here's how: there is a preference for now... possibly to be removed later: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste URLB and pause while the list is filtered (3) Double-click the browser.urlbar.openViewOnFocus preference to switch the value from true to false More info on about:config: Configuration Editor for Firefox.

Thanks for the answer. It seems to be what you said "Top Sites". But the thing is, out of 8 suggestions, I didn't touch the first five sites (since I quit my job and don't have access to them anyway) in two years. The other two seem to be legit. Interestingly the last one (notion) is the one I recently started using it but definitely not so much on FF (but mostly on the app). So not sure what is the logic behind the feature (or how it identify a site a top site). Also, I like the feature (showing top sites), the problem is it's showing the wrong ones. Is there any way to remove/clean this list of top sites without clearing the whole history?

Helpful?

more options

Chosen Solution

OK, managed to get rid of old ones from the list, thanks to @jscher2000 pointing out the name of the feature. I removed them from the "Top Sites" section in the "Home Page" (the one shown in the new tab). Thanks.

Modified by rad.wildrydes.d2ecf5

Helpful?

more options

Removed

Modified by McCoy

Helpful?

more options

McCoy said

rad.wildrydes.d2ecf5 said

I tried shift+del solution which does nothing. Also I cleaned up my history and bookmarks (I searched and deleted everything related to those addresses).

Hello rad.wildrydes.d2ecf5,

Would you try using the cursor down key and then press Delete   -   any luck ?

As mentioned in above it didn't help (that was the very first thing I did). Nor shift+Del :D

Helpful?

more options

rad.wildrydes.d2ecf5 said

As mentioned in above it didn't help (that was the very first thing I did). Nor shift+Del :D

What you hadn't noticed is that I had edited my post;   and emphasized to use the
arrow down key first and then Delete (Shift + Delete on Mac).

But you had already solved the problem, so I removed my post..

Helpful?

more options

McCoy said

rad.wildrydes.d2ecf5 said

As mentioned in above it didn't help (that was the very first thing I did). Nor shift+Del :D

What you hadn't noticed is that I had edited my post;   and emphasized to use the
arrow down key first and then Delete (Shift + Delete on Mac).

But you had already solved the problem, so I removed my post..

Yeah, also did that. Surprisingly it doesn't work, even though it seems to be a feature :/

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.