Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Change default Synchronization & Storage settings

  • 8 replies
  • 1 has this problem
  • 1252 views
  • Last reply by Stans

more options

Greetings,

Happy memorial day from our family to yours! Let us remember those courageously gave their lives. I have been using Mozilla Thunderbird for more than a decade, on multiple Operating Systems, and this is my first post in this great community. Overall, long time Mozilla user and a fan!

Goal:

My objective is to keep only last N days of emails in order to save disk space. I would like to set up 2 gmail accounts.

Expected Behavior:

Right after setting up the email account, if I change settings from Synchronization & Storage page to download emails from only most recent N days, Thunderbird should respect that setting. Most importantly, this setting should only limit the scope of downloading emails, and under any circumstances, should not delete emails on the remote server.

Actual Behavior:

Right after setting up the email account, Thunderbird aggressively starts downloading emails regardless its size or age. If I change settings to sync most recent N days, I still see old emails. These old emails do not away - even after restating the application or even restating the computer. After referring to another post on this forum I also tried using 'Compact folder' option followed by restating the application. It did not seem to do the trick.

The question:

Given the above, I am wondering, somehow - if I changed Thunderbird's default Synchronization & Storage settings to download only most recent N days' emails, would it help me achieve my goal? If it would, I would like to know how.

FWIW - I might be using Mozilla Thunderbird 68.8.1 (32-bit) portable, in Windows 7.

P.S. : I am open to any approach that helps me achieve my goal.

Greetings, Happy memorial day from our family to yours! Let us remember those courageously gave their lives. I have been using Mozilla Thunderbird for more than a decade, on multiple Operating Systems, and this is my first post in this great community. Overall, long time Mozilla user and a fan! '''Goal''': My objective is to keep only last N days of emails in order to save disk space. I would like to set up 2 gmail accounts. '''Expected Behavior''': Right after setting up the email account, if I change settings from Synchronization & Storage page to download emails from only most recent N days, Thunderbird should respect that setting. Most importantly, this setting should only limit the scope of downloading emails, and under any circumstances, should '''not''' delete emails on the remote server. '''Actual Behavior''': Right after setting up the email account, Thunderbird aggressively starts downloading emails regardless its size or age. If I change settings to sync most recent N days, I still see old emails. These old emails do not away - even after restating the application or even restating the computer. After referring to [http://example.com another post on this forum] I also tried using 'Compact folder' option followed by restating the application. It did not seem to do the trick. '''The question''': Given the above, I am wondering, somehow - if I changed Thunderbird's default Synchronization & Storage settings to download only most recent N days' emails, would it help me achieve my goal? If it would, I would like to know how. FWIW - I ''might be'' using Mozilla Thunderbird 68.8.1 (32-bit) portable, in Windows 7. ''P.S. : I am open to any approach that helps me achieve my goal.''

Modified by atalati

Chosen solution

atalati said

Stans said

Let's try a brute approach, go offline just before you click Done or the Advanced Config button. The quickest way would be to unplug the ethernet cable or turn off wifi. This should give you the chance to set mail download options as desired then get back online for the fetching to start.

Tried this approach. This time, Thunderbird downloaded all messages on the account. Regardless their age. I also noticed .msf file and the account dir actually being deleted from ~\Data\profile\ImapMail.

I somehow forgot that these are Gmail accounts setup for IMAP access. Since you're using IMAP, you're going to see ALL the messages that are in your IMAP folders (e.g Inbox). This is how IMAP works. What you see from Tbird is exactly what is present on the server. Tbird mirrors what is on Gmail servers. Note however, that NOT everything you see in Tbird is downloaded for offline access. Tbird downloads the headers only (for all messages in an IMAP folder), not the message bodies. Those Synchronisation settings affect fully downloaded messages (for offline access), not the headers. So, even though you're seeing ALL messages listed in Tbird's messages list, not ALL of them are downloaded to disk in full for offline access. If you wish to also tidy up the inbox list to just a few messages, you can move ALL messages that are older than what you wish to keep in the inbox to the ALL MAIL folder, or simply select the messages and click Archive to send them to that folder. This will keep your inbox tidy, while still keeping your older messages accessible whenever needed.

Read this answer in context 👍 0

All Replies (8)

more options

When setting up a new account, click the Advanced Config button instead of the Done button. This will take you to the new account's settings dialog so that you can make those changes you want before it starts fetching messages.

more options

Stans said

When setting up a new account, click the Advanced Config button instead of the Done button. This will take you to the new account's settings dialog so that you can make those changes you want before it starts fetching messages.

Thank you, Stans. I was able to follow your suggestion. Unfortunately, Thunderbird still downloads last 6 months' emails. I set to download only last 3 days' emails. I made sure that Thunderbird persisted my preference to download last 3 days' emails, still no luck.

more options

Let's try a brute approach, go offline just before you click Done or the Advanced Config button. The quickest way would be to unplug the ethernet cable or turn off wifi. This should give you the chance to set mail download options as desired then get back online for the fetching to start.

Modified by Stans

more options

Stans said

Let's try a brute approach, go offline just before you click Done or the Advanced Config button. The quickest way would be to unplug the ethernet cable or turn off wifi. This should give you the chance to set mail download options as desired then get back online for the fetching to start.

Tried this approach. This time, Thunderbird downloaded all messages on the account. Regardless their age. I also noticed .msf file and the account dir actually being deleted from ~\Data\profile\ImapMail.

Modified by atalati

more options

Chosen Solution

atalati said

Stans said

Let's try a brute approach, go offline just before you click Done or the Advanced Config button. The quickest way would be to unplug the ethernet cable or turn off wifi. This should give you the chance to set mail download options as desired then get back online for the fetching to start.

Tried this approach. This time, Thunderbird downloaded all messages on the account. Regardless their age. I also noticed .msf file and the account dir actually being deleted from ~\Data\profile\ImapMail.

I somehow forgot that these are Gmail accounts setup for IMAP access. Since you're using IMAP, you're going to see ALL the messages that are in your IMAP folders (e.g Inbox). This is how IMAP works. What you see from Tbird is exactly what is present on the server. Tbird mirrors what is on Gmail servers. Note however, that NOT everything you see in Tbird is downloaded for offline access. Tbird downloads the headers only (for all messages in an IMAP folder), not the message bodies. Those Synchronisation settings affect fully downloaded messages (for offline access), not the headers. So, even though you're seeing ALL messages listed in Tbird's messages list, not ALL of them are downloaded to disk in full for offline access. If you wish to also tidy up the inbox list to just a few messages, you can move ALL messages that are older than what you wish to keep in the inbox to the ALL MAIL folder, or simply select the messages and click Archive to send them to that folder. This will keep your inbox tidy, while still keeping your older messages accessible whenever needed.

more options

Stans said

I somehow forgot that these are Gmail accounts setup for IMAP access. Since you're using IMAP, you're going to see ALL the messages that are in your IMAP folders (e.g Inbox). This is how IMAP works. What you see from Tbird is exactly what is present on the server.

Thank you so much Stans for your time and help, much appreciated.

I enabled View -> Layout -> Folder Pane and View -> Layout -> Folder Pane Columns. I chose to display the size column. Please have a look at the attached screenshot. I have set up two different accounts on my Thunderbird. One account is quite older (10+yrs.) and the other is quite recent (~ 2 yrs.). The older account is set up to sync last 2 week's emails, and Thunderbird shows it's size 63 MB. Whereas, the newer account's setting is to sync only last 3 day's emails and Thunderbird shows 300 MB. I am assuming this size column represents the actual disk space being used on my computer hard drive.

I accessed my emails from browser. The older account has 22,592+ emails, whereas the newer one has 3785+. So given that both these are IMAP accounts - somehow my older gmail account "respects" my sync preferences and does not download emails (or even email headers) older than April 2020, but the newer email account downloads messages (or email headers) regardless the age. I am a little lost, to be honest.

more options

No, the size column does not show the space used on local disk. It shows the space used on the IMAP (remote) server since the location is a remote one. You can check and confirm this by opening your profile folder and check the size of the ImapMail folders for those accounts, you'll see they don't match in size with those in that column. I'll get back to you tomorrow for more ideas/tricks you can use to limit the downloaded messages.

more options

The following articles will confirm what I was saying: https://support.mozilla.org/en-US/kb/imap-synchronization#w_configuring-synchronization-and-disk-space-usage

https://support.mozilla.org/en-US/kb/thunderbird-and-gmail#w_synchronizing-folders-labels

For IMAP accounts, Thunderbird will download and display the headers for ALL the messages that are in the IMAP folders on the server. The bodies of those messages, however, will be downloaded according to the synchronization settings that you've put in place. I have multiple Gmail accounts on Tbird, all setup as IMAP, and I've configured all of them to not synchronize (download to computer for offline access) ALL messages. The only synchronization option that I changed to achieve this was to uncheck the "Keep messages for this account on this computer" option immediately after the accounts were added. If Thunderbird had already downloaded (for offline access) a large number of messages, which would take a lot of time, thus using lot's of disk space, then there is a way of forcing it to re-fetch those messages according to your synchronisation preferences. This involves deleting the mbox and msf files from your Tbird profile folder while Tbird is closed (not running/using the profile folder), then relaunching Tbird. This is the only way that I know of, of deleting previously downloaded offline content from your Tbird profile, which could significantly reduce disk space usage by your Tbird profile. My Tbird profile is a mere 85MB and has 7 IMAP accounts on it!