Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Since updating to Mac OS Catalina, Firefox is displaying some fonts/text as boxed question marks.

  • 3 replies
  • 1 has this problem
  • 15 views
  • Last reply by nonne

more options

Since updating to Mac OS Catalina, Firefox is displaying some text/fonts on websites as boxed question marks. I have tried some of the suggested fixes including: 1. lowering the security.sandbox.content.level to a value of 2, 1, or even 0, but no success. 2. Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own. When checked - The boxed question marks appear. 3. The problem is only happening in Firefox. No problem in Safari. (see image)

Thanks for your help and assistance

Attached screenshots

All Replies (3)

more options

Hi noone, glad to see you on Mozilla Support forum.

Looks like some of your font is corrupted that's why it's not showing the text. You can fix this by refreshing your browser.

  • Click the menu icon, then click on “Help”. Click on Firefox's main menu button, represented by three horizontal lines.
  • Click “Troubleshooting Information”.
  • Click on “Refresh Firefox”.
  • Confirm.
  • Click “Finish”.

If it doesn't work, then feel free to ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

Modified by Shashank Shekhar

Helpful?

more options

This is possibly a problem with the Helvetica Neue or Helvetica font that is used for the text in the buttons on the Yahoo news page.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

more options

Thank you for your suggestions.

Shashank Shekhar: Unfortunately, refresh Firefox did not solve the problem.

cor-el: I've looked at a few instances...in one case, the problem font was Georgia, in another case, Helvetica. I've used Mac Font Book to "Restore Standard Fonts" and, in Firefox/Preferences/Language and Appearance/Advanced, checked the box to "Allow pages to choose their own fonts, instead of your selections above". Using these options, it wouldn't seem that I should need to edit fonts.

The problem has not been solved.

Any further suggestions would be appreciated.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.