Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't support HTML5 while other Browsers do. Latest Ubuntu 20.04. LTS

  • 5 replies
  • 2 have this problem
  • 991 views
  • Last reply by lu.menard

more options

So the problem is that Firefox doesn't play any HTML5 content. Weirdly except for Youtube. Youtube works just fine. But every other Website shows errors. Even songsterr.com. I'm using latest Firefox 76.0.1 on a recent Ubuntu 20. 04 LTS installation. Usual troubleshooting like updates doesnt work because "sudo apt-get upgrade" doesn't find any updates. I tried the same websites in the latest version of Chromium and they work perfectly fine. I couldn't find a mistake in the firefox settings or something so I'm confused. Disabling Plugins didn't change anything and turning of tracking protection didn't either. What is the Problem here and how can I solve it?

Chosen solution

Note that in such cases you can check the Web Console for possible error messages.

Read this answer in context 👍 0

All Replies (5)

more options

On Linux, I believe Firefox needs the FFmpeg package installed (in the system, not as an add-on) in order to decode MP3/MP4/H.264/etc.

Edit

Note: Most Youtube videos are transcoded to WebM, so Firefox can play most Youtube videos without MPEG decoding support. To see which formats your Firefox supports, I have a general test page here: https://www.jeffersonscher.com/sumo/html5-video.html

Modified by jscher2000

Helpful?

more options

Chosen Solution

Note that in such cases you can check the Web Console for possible error messages.

Helpful?

more options

I have allways problems with Firefox and a website which displays real time video chats, that's what i can tell you. It is constantly for more than 3 years ok ?

Before, the main problem was under Linux with the system's screen capture, only on Firefox, not with Opera or Chrome : the printscreen key when pressed, made the flash video window to close. Now this problem with Flash on Firefox under Linux and with this website, is fixed.

Now, the problem with this website is that Firefox and Opera ask "Run Flash" and if I deactivate Flash on this page, no video plays : black window.

Analysis : - With Chrome : no problem (as usual) - With Firefox in safe mode it is the same - With a default Firefox profile from another user account of my Linux Mint 19.3 64 bits, same problem - Under a Linux Mint 19.3 from a Live Installation USB removable device, it works well, even after upgrading Firefox to v77

So WTF ?

Helpful?

more options

Helpful?

more options

cor-el said

Did you try Firefox from the Mozilla server with a new fresh profile ? See "Creating a profile":

Are you talking to me ? (lol) If yes : a new fresh profile on my Firefox from the Linux Mint depositories, changes nothing, I know this because Firefox is installed on all my Mint accounts and some profiles are the default ones from the first installation, never used... and I don't know if I can install 2 Firefox on this or must I begin by uninstalling this one ?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.