Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

instruction step #2 in Manually Enabling and disabling DNS-over-HTTPS is wrong - In the General panel, NO scroll down to Network Settings

more options

In the article Firefox DNS-over-HTTPS on https://support.mozilla.org/en-US/kb/firefox-dns-over-https the section to: Manually Enabling and disabling DNS-over-HTTPS, says: You can enable or disable DoH in your Firefox connection settings:

However, in Step 2 below, there is no scrolling available nor is there a NETWORK SETTINGS section available on the page to click SETTINGS, and therefore no further access to accomplish this process. This is on a iMac.

1. Click the menu button Fx57Menu and select Preferences. 2. In the General panel, scroll down to Network Settings and click the Settings… button. 3. In the dialog box that opens, scroll down to Enable DNS over HTTPS. On: Select the Enable DNS over HTTPS checkbox. Select a provider or set up a custom provider. Off: Deselect the Enable DNS over HTTPS checkbox. toggle doh Click OK to save your changes and close the window.

Chosen solution

If the scroll bar is missing on your Preferences page, or other pages, maybe it's one of those Mac things you will find puzzling as a former Windows user.

Recent versions of MacOS often have an invisible scrollbar that only appears when you are actively trying to scroll a page. This is a system-level setting that Firefox honors, so if you think that might be the issue, check out the "Show scroll bars" topic in the following article:

https://support.apple.com/guide/mac-help/change-general-preferences-mchlp1225/10.15/mac/10.15

Read this answer in context 👍 1

All Replies (7)

more options

That part of the settings should be visible to you. Are you using a version of Firefox that you downloaded from the official Firefox website or from elsewhere?

Helpful?

more options

Hi Wesley,

I downloaded from Mozilla.org and update is automatic. I'm on an iMac and just learning as was MS Windows user. I tried accessing from both Firefox and Safari and can't see that section and no scroll bar available so assuming page was complete.

Helpful?

more options

Hi

You wrote: "However, in Step 2 below, there is no scrolling available nor is there a NETWORK SETTINGS section available on the page to click SETTINGS, and therefore no further access to accomplish this process. This is on a iMac. "

I'm on a Macbook Air, macOS Catalina latest, Firefox 76. as well and I do see the Network Settings section when I scroll. Please post a screenshot so we can see exactly what you see and can help you further.

Cheers! ...Roland

Helpful?

more options

Chosen Solution

If the scroll bar is missing on your Preferences page, or other pages, maybe it's one of those Mac things you will find puzzling as a former Windows user.

Recent versions of MacOS often have an invisible scrollbar that only appears when you are actively trying to scroll a page. This is a system-level setting that Firefox honors, so if you think that might be the issue, check out the "Show scroll bars" topic in the following article:

https://support.apple.com/guide/mac-help/change-general-preferences-mchlp1225/10.15/mac/10.15

Helpful?

more options

To Jscher2000 (and Roland),

Roland, thanks for the confirmation that you are able to see that setting - although, I hesitate to say it, even though we have the same version OS and Firefox, I've read that MacBook Air and iMac have some portability differences due to the different Intel chips (i3,i5, etc) depending on the particular model and timeframe bought - not sure if that could be the case. Could simply be the system preferences I selected?

Jscher2000, thanks for pointing out the hidden aspect that I wouldn't have realized from being a prior MS Windows user. The article helped and I was able to then see the scroll bar that wasn't displayed before. Appreciate everyone's help very much...

Helpful?

more options

Hi again:

"Roland, thanks for the confirmation that you are able to see that setting - although, I hesitate to say it, even though we have the same version OS and Firefox, I've read that MacBook Air and iMac have some portability differences due to the different Intel chips (i3,i5, etc) depending on the particular model and timeframe bought - not sure if that could be the case. Could simply be the system preferences I selected? "

I very much doubt it. I've been using Macs (and Windows and far too many other computers) since 1995 and Firefox since it wasn't called Firefox and never seen a CPU difference causing Firefox to display different preferences dialogues. Again, please post a screenshot showing what you see. And of course try what jscher says i.e. please see if you can scroll down.

Cheers!

...Roland

Helpful?

more options

Hi Roland,

Thanks for the reply, yeah, it was just a guess on my part, something I'd read in MacWorld, etc., had related that MacBook Air / Pro, had some features as part of their OS that the iMac doesn't have and while those dealt with drawing on the screen, etc., it just indicated to me that they're not equals in all respects - although, as you say, there probably wouldn't be preference differences? So it was just a straw grasping - interestingly enough, when I bought my iMac and tried to establish my Apple-ID, well, let's just say it took 3 front line tech support calls before they escalated it to a senior tech who remotely connected and said he'd never ran into such a problem as trying to do something that one would thing is the most simplest straightforward program to accomplish. It took 3 days to finally resolve and I've had a few other issues with this system. I'm tempted to swap it out for a replacement.

I finally got the scrolling inside the general preferences page to work, lol. Thanks for your investment of time and followup.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.