Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox and Chrome wont load google.com or captchas "SSL_ERROR_BAD_CERT_DOMAIN" error

  • 6 replies
  • 1 has this problem
  • 243 views
  • Last reply by LaW

more options

Both Chrome and Firefox wont load google.com or any captchas. The Discord log in also requires a captcha, th is wont load either. I get the error "SSL_ERROR_BAD_CERT_DOMAIN" when attempting to load google.com. This does not occur on any other website. I've already tried using another profile, renaming the cert file, setting windows time and date to automatic and running malwarebytes. The problem persists.

https://www.google.com/

Unable to communicate securely with peer: requested domain name does not match the server’s certificate.

HTTP Strict Transport Security: false HTTP Public Key Pinning: true

Certificate chain:


BEGIN CERTIFICATE-----

MIIDfjCCAmagAwIBAgIQNRqFxSaATalMGz4ZlBXBtTANBgkqhkiG9w0BAQsFADAj MSEwHwYDVQQDDBhEaWdpQ2VydCBHbG9iYWwgUm9vdCBHMUEwHhcNMTkwNDA1MDk0 NDM4WhcNMzAwNDA1MTk0NDM4WjAcMRowGAYDVQQDDBF3d3cuZ29vZ2xlLmNvbS5h dTCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEBALM9RDfviXLtvVRTktFA 44cXX6Ez6W8ulsOH+xNLwUq0aZnfjLAt1sTg1THDj8XqXHytD+vqtOWkv4/iWf4C 0yBmljluIslsdimrQhQRGJh3Goio8nLG+/thNjlDjuOh04Jo09YEU9r6fDRstn/b DKyaU3eKhJZ6QbAzUQb4mKpXR9Xw70VcwT16nfN9JIKiAWwhEqRL+c2tV5DcChwc UqsHvyccraD82eFL3K7LH61q2kCQDhxcS4WfjVspcU5fiTmL+czT3cAMhY4FDsRd 2udxvankHH+CbdoOcRODlcmy2V0lOSnrLXRfeqdnR1Wscq43rxsYqvyugNpN0BR9 KtkCAwEAAaOBtDCBsTATBgNVHSUEDDAKBggrBgEFBQcDATAMBgNVHRMBAf8EAjAA MA4GA1UdDwEB/wQEAwIFoDA8BgNVHREENTAzghF3d3cuZ29vZ2xlLmNvbS5hdYIP Ki5nb29nbGUuY29tLmF1gg1nb29nbGUuY29tLmF1MB8GA1UdIwQYMBaAFLnaK2zy VfI6Vj7KeoW6/iwDog4pMB0GA1UdDgQWBBRN+D1mXNPnod7CfJYS90hAMeltBTAN BgkqhkiG9w0BAQsFAAOCAQEAGfJch7obdXr4czz6veN+4DGGxEJW/tbYZcRPBymh 0xA3GrcAzjO+v2+HFhU3ZftqJLJ7PZ0lCoXGof8DLEjrjdOdgTH823RPbb6GYmdA 7/ZCciqTJXivh0u5kaOb73WMuIqcCAk7ESgKOmGz6lm+LO5D/ZMlhd6/zZh/BVGC krcOzu+aeQ7AzjuAYd9u8DAiBsg/u26QZSbLWc4WLzA28EcDf2UygfHsPLa7WzoL qkNPv3TZF/mjANNsRGizrtMrzF8TzKFHm2vOMUtwukKDgENZKpsfuW98VsMDbZ/K O+XYlu/Ml/XP0I/EgKY+HcaB7ubiJVva5WqD7n9fKrjZCg==


END CERTIFICATE-----
Attached screenshots

Chosen solution

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Read this answer in context 👍 1

All Replies (6)

more options

I would like to add that "DigiCert Global Root G1A" does not exist in my certificates manager

Helpful?

more options

Unfortunately, as far as I can tell, that is not the real Google.com.au certificate, and of course it doesn't match google.com. There appears to be an interloper of some kind. Since multiple browsers are affected, I suspect it's something external that has hooked into Windows to intercept browser connections.

As a test, could you try DNS over HTTPS, a feature that bypasses Windows when looking up the IP address corresponding to a domain name, and instead uses Cloudflare. More info in this article: Firefox DNS-over-HTTPS.

Does that make any difference?

Helpful?

more options

With DNS enabled over HTTPS (Cloudflare) google.com still does not load. The problem persists I have since tried turning off all browser extensions. Google.com.au will now also not load

Helpful?

more options

Chosen Solution

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Helpful?

more options

Changing the proxy setting to "no proxy" has solved this. Google.com now loads and captchas in Firefox work. Thanks for the help

Helpful?

more options

I would like to add, if the captcha not loading persists on other browsers (chrome, ie) and programs, check and change your windows proxy settings. Remove any proxy in Windows settings you have not set, you may need to edit ProxySettingsPerUser found in "hkey_local_machine\software\policies\microsoft\windows\currentversion\internetsettings" to 1 so that the changes you made in windows proxy settings are saved

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.