Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I broke watch mp4 in browser

  • 4 replies
  • 1 has this problem
  • 27 views
  • Last reply by G_Eak

more options

I just updated my Firefox on my windows 7 laptop (76.0.1) and could no longer stream live video on Youtube. Yesterday I went thru various troubleshooting sites and finally got Youtube streams to work again.

This morning I see that when I watch an MP4, Firefox downloads the video. After download, it ask me What should Firefox do with this file? Default Windows Media Player.

What did I break? How do I have Firefox start video immediately in Firefox?

Thanks!!!

Chosen solution

Thanks for the reply McCoy,

I had checked media.play-stand-alone. It was set to true. I gave up. After copying passwords & favorites file, I uninstalled Firefox, deleted profile and reinstalled Firefox. That fixed it. So far, all Youtube is working and videos play in Firefox.

I suspect there was an add-on pseudo running but not showing up in "Add-ons".

Appreciate the reply!!! issue closed.

Read this answer in context 👍 0

All Replies (4)

more options

Dam. The original problem is back. Firefox is driving me nuts.

https://www.youtube.com/watch?v=3pN9WU1S8nQ Your browser does not currently recognize any of the video formats available. Click here to visit our frequently asked questions about HTML5 video

Helpful?

more options

I use to run AdBlocker (or something like that) but see that it is not showing up in Add-ons, extensions, Plugins.

Frustrating.

Helpful?

more options

G_Eak said

This morning I see that when I watch an MP4, Firefox downloads the video. After download, it ask me What should Firefox do with this file? Default Windows Media Player.

Hello   G_Eak,

Would you try this please :

Type in the address bar   about:config   and press Enter.
(ignore the warning)

Type in the search bar and look for the preference :

media.play-stand-alone   and make sure its value is set to   true.

If you had to change the value, then close and restart Firefox.

Any luck ?

Helpful?

more options

Chosen Solution

Thanks for the reply McCoy,

I had checked media.play-stand-alone. It was set to true. I gave up. After copying passwords & favorites file, I uninstalled Firefox, deleted profile and reinstalled Firefox. That fixed it. So far, all Youtube is working and videos play in Firefox.

I suspect there was an add-on pseudo running but not showing up in "Add-ons".

Appreciate the reply!!! issue closed.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.