Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Any Firefox versions above 73+ are slow after upgrading from 72.0.2

more options

Since Firefox 73 was released I noticed after upgrading that Firefox became insanely slow on a significant number of websites. For example youtube.com or finance.yahoo.com were really slow at loading compared to Firefox 72. CPU usage on one of my cores goes very high.

This page for example would load the main screen fairly quick then it would stall while it loads all the stock widgets on the page which it doesn't do with Firefox 72 :

https://finance.yahoo.com/quote/SPLK

In general I've noticed an overall loading sluggishness even with simple pages like google.com etc. Just not as snappy to load.

In all cases Firefox 72 and Chrome work fast and snappy. Tried Firefox 73 and Firefox 76+ and they run awful.

When I first noticed the issue back when Firefox73 was released, I gave up and rolled back to a Firefox 72 backup and thought it was probably a bug that would be sorted later. Tried again today with Firefox 76 and I still have the same issue so I have had to roll back to Firefox 72 again.

Things I have tried that have NOT helped :

Disabled all addons/extensions Set Default Theme Disabled DNS over HTTPS Cleared cache/cookies Deleted content-prefs.sqlite Disabled hardware acceleration Tried different values for content process limit Disabled smooth scrolling

Can anyone help please or am I going to be stuck on Firefox 72 forever?

Thanks.

All Replies (2)

more options

No one else seeing this?

Any suggestions please?

Helpful?

more options

Hi Laxity, glad to see you on Mozilla Support Forum.

You can speedup your browser by following way:-

  • Type “about:config” into the location bar and hit Enter.
  • First, set “network.http.pipelining” to “true”.
  • Now, set “network.http.proxy.pipelining” to “true”.
  • Then change “network.http.pipelining.maxrequests” to a larger number like 8 (This means that it will make about 8 requests at once).
  • Now search for max-connections in the search bar.
  • Change “network.http.max-connections” to 96.
  • Then, change “network.http.max-connections-per-server” to 32.
  • Finally, right-click anywhere and then select New and then Integer value.
  • Name it “nglayout.initialpaint.delay” and set its value to 0 i.e. “Zero”.

(This value is the total amount of time that the browser waits before it acts on the information it receives. If you have a broadband connection, you’ll load pages faster now.)

Optionally, here are some more options for your about:config to increase the speed.

  • Set “network.dns.disableIPv6” to “false”.
  • Then, set “plugin.expose_full_path” to “true”.

Hope it helps !

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.