Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Why cant I block google cookies? All other blocks work??

  • 10 replies
  • 1 has this problem
  • 11 views
  • Last reply by Davidddeee

more options

I've tried the 2 solutions already covered [https://support.mozilla.org/en-US/que.../1285636|here] and [https://support.mozilla.org/en-US/que.../1275740|here]

Ive blocked all possible http/https and www combinations of google.com and also blocked it using 'page info' 'permissions'. I've also deleted my cookies.sqlite file, but google.com is still being allowed to put cookies and store data in my browser.

I've got every possible block, yet none of them are working.

I have many other sites blocked using the same methods without problem, also I can add any other new site to my block list and it will stand and the cookies will be successfully blocked.

I'm using a profile that was setup only a few days ago, as other permissions are working fine this can only be considered a problem with blocking this specific url: google.com

I'm using FF 75.0 x64 on Xubuntu 20.04 (snap)

As this is a new install I've spent a number of hours tweaking my about:config settings, installing and configuring extensions, saving logins and other things, the last thing I want to do is have to refresh and start all over again.

Can someone please tell me how to fix this problem?

Attached screenshots

All Replies (10)

more options

Just setting the Set Cookies permission to Block should work fine.

Have you made sure to clear the cookies that are already on your system from the Google website? Denying Google permission to save cookies won't remove cookies that already exist on your system, it will just prevent the creation of new cookies.

Modified by Wesley Branton

Helpful?

more options

Hi Wesley yes that would work, but it would also block cookies from all other websites, which I dont want to do.... I want to block only selected cookies from the biggest privacy invading companies, ie: google, facebook and the likes.

I've cleared all cookies many times, also all cookies are set to be removed on browser close. As already mentioned every block possible is active, but google.com cookies are still being accepted.

Any new blocks I apply to any other domain take effect and actually work, but not google.com

Thanks for the suggestion, but unfortunately it hasnt helped

Helpful?

more options

Davidddeee said

Hi Wesley yes that would work, but it would also block cookies from all other websites, which I dont want to do.... I want to block only selected cookies from the biggest privacy invading companies, ie: google, facebook and the likes.

Hello   Davidddeee,

Maybe you should read Wesley's post again ......

And then take a look at this article :

https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox

You would be clearing cookies from   Google.com   only.

Helpful?

more options

McCoy said

Davidddeee said

Hi Wesley yes that would work, but it would also block cookies from all other websites, which I dont want to do.... I want to block only selected cookies from the biggest privacy invading companies, ie: google, facebook and the likes.

Hello   Davidddeee,

Maybe you should read Wesley's post again ......

And then take a look at this article :

https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox

You would be clearing cookies from   Google.com   only.

Hi McCoy, I read and understood the reply perfectly well. If you would have read my comments you would see that i've done everything that can be done.

I've already said that all the blocks are in place and that all cookies are removed on firefox close, i've even posted screenshots to show this. I've performed all of the actions listed in the link you provided in the privacy setting tab and the page info tabs, yet the cookies still persist.

I've attached more screenshots to show the blocks and cookie(s)

edit: also as already stated, any new blocks that I apply using the same method work and the stated cookies are blocked, there is nothing wrong with the method i'm using. It should work... but it isnt

Modified by Davidddeee

Helpful?

more options

Davidddeee said

Hi McCoy, I read and understood the reply perfectly well. If you would have read my comments you would see that i've done everything that can be done.

With all due respect;   I had read your comments,   but did not see you mention having cleared cookies and site data on google.com.
If I have somehow missed that :   please, accept my apologies.

Helpful?

more options

Despite all that, in the page info 'securties' tab. It says:

Is this website storing in formation on my computer? Yes, cookies! Lol

Helpful?

more options

Did you see my last post ?

(we posted almost simultaneously ... )

Helpful?

more options

McCoy said

Davidddeee said

Hi McCoy, I read and understood the reply perfectly well. If you would have read my comments you would see that i've done everything that can be done.

With all due respect;   I had read your comments,   but did not see you mention having cleared cookies and site data on google.com.
If I have somehow missed that :   please, accept my apologies.

Sure its no problem, thanks for the suggestion.

Unfortunately this weird problem persists.

Helpful?

more options

As you seem to have done just about everything in the book,   I went to
see if maybe there's an add-on that might do the trick and found this one :

https://addons.mozilla.org/en-US/firefox/addon/cookie-autodelete/

Worth a try .....

Helpful?

more options

Thanks for the suggestion, I did resort to an addon previously, which did fix the problem. But that solution requires I give permission for said addon to view, edit and record all of my browsing data, which is likely a worse privacy invasion than letting googhell store cookies.

It's gonna be a ball ache but it seems my only option is to start a new profile and configure it all again.

Modified by Davidddeee

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.